Fix: UDL Dialog for SQL Server OLE DB Provider Generates Empty Server List (326362)



The information in this article applies to:

  • Microsoft OLE DB Provider for SQL Server 2000 2000.80.194
  • Microsoft OLE DB Provider for SQL Server 2000 2000.80.380.0
  • Microsoft OLE DB Provider for SQL Server 2000 2000.81.7713.0
  • Microsoft Data Access Components 2.6
  • Microsoft Data Access Components 2.7

This article was previously published under Q326362

SYMPTOMS

The Server drop-down list may be empty even if you have Microsoft SQL Server (for example, version 7.0 or version 6.5) installed on your network.

The Server drop-down list is empty if the following conditions are met:
  • You have clicked Microsoft OLEDB Provider for SQL Server on the Provider tab of the Data Link Properties dialog box (UDL dialog box).
  • You have not installed SQL Server 2000 on your subnet, but have only installed SQL Server 6.5 or SQL Server 7.0 on your subnet.
  • You have either MDAC 2.6 or MDAC 2.7 installed on your client.
NOTE: This problem does not occur with MDAC 2.5.

CAUSE

Microsoft OLEDB Provider for SQL Server (SQLOLEDB) uses the following two methods to enumerate all the existing servers on the particular subnet:
  • Method 1: SQLOLEDB calls NetServerEnum API to enumerate all the SQL Server instances on the particular subnet.
  • Method 2: SQLOLEDB sends a UDP packet to enumerate all the SQL Server 2000 instances on the particular subnet.
If there is no SQL Server 2000 on the subnet, this second call returns an empty list. When the two calls return successfully, SQLOLEDB Provider merges these two list to populate the Server drop-down list in the UDL dialog box.

Because of a bug in SQLOLEDB provider, if the second call returns an empty list, SQLOLEDB provider does not populate the Server drop-down list.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 Date         Version            Size     File name     Platform
 -----------------------------------------------------------
 26-Jul-2002  2000.081.9001.013  450,560  Sqloledb.dll     x86
				

WORKAROUND

To workaround this problem, install SQL Server 2000 in your subnet. If you do not have SQL Server 2000, or you do not want to install SQL Server 2000, install this fix.

MDAC 2.7 SP1 also includes this hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB326362