MSExchangeIS Event ID 5000, 9538, and 9098 Messages Occur in Small Business Server 2000 (326305)



The information in this article applies to:

  • Microsoft Small Business Server 2000
  • Microsoft Small Business Server 2000 SP1

This article was previously published under Q326305

SYMPTOMS

The Microsoft Exchange Information Store Service (also known as MSExchangeIS) and its dependent services may not start automatically when the computer starts. If you try to manually start the Microsoft Exchange Information Store Service, you may receive the following error message:
Service Specific Error 0 when starting the Information Store service.
You may also receive the following event messages in the Event Viewer Application log:

Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9538
Date: 6/7/2001
Time: 12:07:34 PM
User: N/A
Computer: EX1
Description: Error 0x80040154 calling StrInitialize in REAPI.DLL.

-and-

Event Type: Error
Event Source: MSExchangeIS Event
Category: General
Event ID: 5000
Date: 6/7/2001
Time: 12:07:34 PM
User: N/A
Computer: EX1
Description: Unable to initialize the Microsoft Exchange Information Store service. Error 0x80040154.

-and-

Event Type: Error
Event Source: MSExchangeSA
Event Category: Monitoring
Event ID: 9098
Date: 6/7/2001
Time: 12:07:48 PM
User: N/A
Computer: EX1
Description: The MAD Monitoring thread was unable to read its configuration from the DS, error '0x80041001'.

CAUSE

This problem occurs because the Exchange 2000 Server Simple Mail Transfer Protocol (SMTP) Service extensions are either missing or corrupted. This behavior causes loss of functionality between Exchange 2000 and the SMTP Service, which is a necessary service that is installed as a subcomponent of Microsoft Internet Information Service (IIS) version 5.0.

The messages that are listed in the "Symptoms" section may occur if any of the following conditions are true:
  • IIS 5.0 has been removed.
  • The SMTP Service subcomponent has been removed from IIS 5.0.
  • IIS 5.0 has been removed, and then reinstalled as a Windows 2000 component that does not have the required SMTP Service subcomponent.
  • IIS 5.0 has been removed, and then reinstalled as a Windows 2000 component that has the appropriate list of subcomponents, but the Exchange 2000 Server SMTP Service extensions have not been reinstalled.

RESOLUTION

To resolve this problem, follow these steps:
  1. Confirm that the Exchange 2000 SMTP Service extensions are missing. To do so:
    1. Type telnet 127.0.0.1 25 at the command prompt of SBS 2000 or SBS 2000 SP1 to bring up the "220 server.domain.com Microsoft ESMTP Mail Service" entry.
    2. Type EHLO, and then press ENTER to bring up a list of "250" command verbs.

      If there are no verbs with "X" at the beginning of their names, the SMTP Service Extensions are missing.
  2. Completely back up the system partition, including the system state, and the Exchange 2000 database files.
  3. Confirm that IIS 5.0 has been properly reinstalled to include the required Exchange 2000-dependent subcomponents:
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Add/Remove Programs.
    3. Click Add/Remove Windows Components in the left pane.
    4. In the Windows Components Wizard, locate Internet Information Services (IIS) in the list of components.

      If the Internet Information Services (IIS) check box is selected, IIS is installed. To confirm what subcomponents are installed, click Internet Information Services (IIS), and then click Details.
    5. If IIS is not installed, click to select the Internet Information Services (IIS) check box, and then click Details.
    6. Select and confirm the IIS 5.0 subcomponents, and then click OK.

      The following list contains the minimum IIS 5.0 subcomponents that are required before you install Exchange 2000:
      • Common files
      • Internet Information Services snap-in
      • SMTP service
      • Network News Transfer Protocol (NNTP) service (for newsgroups)
      • World Wide Web service
    7. Click Next, and then click Finish.
  4. Restore the Exchange 2000 SMTP Service extensions.

    The methods that you can use to restore the Exchange 2000 SMTP Service extensions depend on how many IIS 5.0 subcomponents were removed.
    • If the SMTP Service is the only IIS subcomponent that was removed, but the rest of the IIS 5.0 subcomponents remain installed, and if Exchange 2000 Service Pack 2 (SP2) or later has been installed, use the Smtpreinstall.exe command-line utility. The Smtpreinstall.exe command-line utility is located in the Server\Support\Utils\i386 folder of Exchange 2000 SP2 or later.

      To use the Smtpreinstall.exe utility:
      1. Copy Smtpreinstall.exe to the Exchsrvr\Bin folder.
      2. From the Exchsrvr\Bin folder, open a command prompt, and then run the following command:

        smtpreinstall.exe

      3. Restart the computer when you are prompted.
    • If IIS 5.0 was removed as a component or if more than the SMTP Service subcomponent was removed from IIS 5.0, reinstall Exchange 2000 over the existing installation as part of the integrated setup of SBS 2000/SBS 2000 SP1.

      NOTE: If you reinstall Exchange 2000 over an existing Exchange 2000 installation, the database files and permissions remain intact.

      To reinstall Exchange 2000:
      1. Start the SBS 2000 Setup Wizard from CD 1. To do so, you can either use the Autorun menu option or run the following command on the root of SBS 2000 CD 1:

        setup.exe

      2. Type the logon information for the administrator, and then click Next.
      3. Click Next, click Next, and then click Next again.
      4. In the Component Selection page, click Reinstall in the Action column for Microsoft Exchange 2000 Server, and then click Next.
      5. Verify the selection in the Installation Summary page, and then click Next. The Exchange 2000 reinstallation continues.
  5. Reinstall the Exchange 2000 service packs and hotfixes.For additional information about how to obtain the latest Exchange 2000 Service Pack, click the article number below to view the article in the Microsoft Knowledge Base:

    301378 How to Obtain the Latest Exchange 2000 Server Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Exchange 2000 uses SMTP service, which is a component of IIS 5.0. Exchange 2000 installs the SMTP Service extensions that extend functionality with the base SMTP Service.

To resolve the behavior in Exchange 2000:
  1. Install the necessary IIS 5.0 components that are listed in Step 3 g in the "Resolution" section of this article.
  2. Restore the Exchange 2000 SMTP service extensions. To do so, either reinstall Exchange Server 2000 or use the Smtpreinstall.exe utility that is included with Exchange 2000 SP2 on servers that are running Exchange 2000 SP2 or later. Details of each procedure are listed in the "Resolution" section in this article.For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

    290290 XIMS: Cannot Send Mail After Re-Installing the IIS SMTP Service

To make sure that Exchange 2000 Server retains full functionality after the installation is complete, make sure that all five IIS 5.0 components are installed before you install Exchange 2000 Server. SMTP Service and the NNTP service depend on the Common files, the IIS Snap-in, and World Wide Web service components of IIS 5.0. If you remove of any of these components, you remove both the SMTP Service and NNTP Service components of IIS 5.0.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbprb KB326305