You receive an abnormal program termination error message when you run AutoDiscovery in Visio 2002 (326289)



The information in this article applies to:

  • Microsoft Visio 2002 Standard
  • Microsoft Visio 2002 Professional
  • Microsoft Visio Network Central
  • Microsoft Visio Network Equipment

This article was previously published under Q326289

SYMPTOMS

When you try to run AutoDiscovery after you upgrade from Visio 2000 Enterprise Edition, you may receive an error message similar to the following:
Runtime error C:\Program Files\Microsoft Office\Visio10\Dll\Dmonitor.exe - Abnormal program termination.

CAUSE

This behavior may occur if files from the Visio 2000 installation were not removed during the upgrade.

RESOLUTION

To resolve this problem, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. Click Visio 2002, and then click Add/Remove.
  4. Follow the on-screen instructions to remove Visio.
  5. Click Start, and then click Search.
  6. Click All files and folders.
  7. In the All or part of the file name box, type dmonitor.exe, and then click Search.
  8. Right-click Dmonitor.exe in the search results list, and then click Open Containing Folder.
  9. On the Edit menu, click Select All, right-click any file in the folder, and then click Delete.
  10. Install Visio 2002, and then install Visio Enterprise Network Tools.

MORE INFORMATION

For additional information about Visio Enterprise Network Tools, click the article number below to view the article in the Microsoft Knowledge Base:

300019 Visio2002: AutoDiscovery and Layout Solution in Visio 2000 Is Missing After You Install Visio Enterprise Network Tools


Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbtshoot kberrmsg kbprb KB326289