XCCC: Mobile Information Server Notifications Do Not Work After You Upgrade to Exchange 2000 SP3 (326232)



The information in this article applies to:

  • Microsoft Exchange 2000 Server SP3
  • Microsoft Mobile Information Server 2002
  • Microsoft Mobile Information 2001 Server

This article was previously published under Q326232

SYMPTOMS

If you are using a server that is running Exchange 2000 Service Pack 3 (SP3) that has Mobile Information Server Exchange Event Source installed on it, notifications are not sent to users. This behavior also occurs if you apply SP3 to a server that is running Exchange 2000 that has Mobile Information Server Exchange Event Source installed on it.

CAUSE

This problem occurs because Exchange 2000 SP3 modifies the permissions for the accounts that Mobile Information Server uses to send notifications.

RESOLUTION

To resolve this problem, perform the following procedure on each server that is running Exchange 2000 SP3 that has Mobile Information Server Exchange Event Source installed:
  1. On the Exchange 2000 server that has Exchange Event Source installed, start Exchange System Manager.
  2. Expand Servers, right-click the server that is used to send notifications, and then click Properties.
  3. Click the Security tab.
  4. Click the Exchange Event Source account, click to select the Allow check box next to Read metabase properties, and then click OK.
After you apply the permissions to the Exchange Event Source account for each Exchange 2000 server that has Mobile Information Server Exchange Event Source installed, you must restart Component Object Model (COM+) on each of these servers:
  1. On the Exchange 2000 server that has Exchange Event Source installed, start the Component Services tool.
  2. Expand My Computer, and then expand COM+ Applications.
  3. Right-click Exchange Mobility Event Sink, and then click Shut Down.
  4. Right-click Exchange Mobility Event Sink, and then click Start.
  5. Quit Component Services.
NOTE: If a notification is sent to any user while you are performing this procedure on your Exchange 2000 server, the bindings are disabled. In this situation, the user must repersonalize the device to set the bindings.

To reset a users device to receive notifications, instruct the user to perform the following procedure:
  1. Open a browser window, and then type the URL of the Personalization Web page (for example, type http://Exchange2000_Server_Name/Airweb).
  2. Click the device that is configured to receive notifications in the left pane.
  3. Under Microsoft Outlook Mobile Access-Notifications, click to clear the Forward a notification to my device when Mobile Inbox receives mail check box, and then click Apply.
  4. Under Microsoft Outlook Mobile Access-Notifications, click to select the Forward a notification to my device when Mobile Inbox receives mail check box, and then click Apply.
  5. Repeat these steps for every device that is set to receive notifications.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB326232