SMS: Advertisements May Go to the Wrong Client If the .lkp File on the CAP Is Locked (326114)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q326114
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

Microsoft Systems Management Server (SMS) program advertisements may go to the wrong clients if any .lkp files on the client access point (CAP) are locked by a client. When an .lkp file is locked by a client, the file cannot be updated from the site server. For example, an advertisement for a group of computers may be incorrectly distributed to a group of users.

CAUSE

If any .lkp files on the CAP are inadvertently locked by clients for a long time, an .ins file name that was previously assigned to another collection resource may be generated again. This behavior may occur if several old advertisements are deleted and several new advertisements are created, because the random-name algorithm that is responsible for making sure that the targeted collection resources are uniquely identified by the .ins files on the CAP may inadvertently generate an .ins file name that was previously assigned to another collection resource. This causes the advertisement to be made available to the wrong resources.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-May-2002  20:10  2.0.1493.4190  827,664  Baseutil.dll  Alpha
   01-May-2002  17:10  2.0.1493.4154  179,984  Inboxmgr.dll  Alpha
   01-May-2002  20:10  2.0.1493.4190  537,536  Baseutil.dll  x86
   01-May-2002  17:10  2.0.1493.4154  112,016  Inboxmgr.dll  x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This fix has two effects:
  • The random-name algorithm has been enhanced to reduce the chance that an .ins file name will be regenerated.
  • A registry change has been introduced. You can optionally make a manual change to the registry to affect the behavior of Inbox Manager when a client holds file locks in the Offerinf.box folder on the CAP. If this situation occurs when an update to the files in the Offerinf.box folder is pending, a five-second grace period is permitted before the file locks are forcibly disconnected to make sure that the .lkp files are replicated successfully. For more information about this change, see the "Optional Change to Forcibly Disconnect Clients" section later in this article.

How to Install the Hotfix

To install the update, use the appropriate method.

Using the Hotfix Installer

Note This method is for only Intel-based computers.
  1. Copy the update folder structure to a share on your network. Sms2.0-kb326114-sp4-x86-enu.exe is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Log on to your site server by using an account with administrator permissions.
  3. On the site server, quit the SMS Administrator console (if it is running).
  4. Run Sms2.0-kb326114-sp4-x86-enu.exe, and then follow the instructions in the wizard. You can run the file in Quiet mode by using the /s switch.

Using a Manual Installation

  1. Quit the SMS Administrator console, and then stop the SMS Site Component Manager and SMS Executive services.
  2. Replace the Baseutil.dll file in the Sms_root_folder\Bin\Platform folder with the version from the hotfix.
  3. Replace the Inboxmgr.dll file in the Sms_root_folder\Bin\Platform folder with the version from the hotfix.
  4. Restart the SMS Site Component Manager and SMS Executive services.

Optional Change to Forcibly Disconnect Clients

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Log on to your site server by using an account with administrator permissions.
  2. Stop the SMS Site Component Manager and SMS Executive Services.
  3. Using Registry Editor, locate and then click the following registry key:

    HKLM\Software\Microsoft\SMS\Inbox Source\Inbox Rules\

  4. Under the key that you located in step 3, locate the numeric subkey that has a Destination Inbox Name of "Offer Info CAP."
  5. For this subkey, change the data value of the Replication Flags value to 2c (hexadecimal).
  6. Quit Registry Editor, and then restart the SMS Site Component Manager and SMS Executive services.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbSMS200preSP5fix kbbug kbfix KB326114