SMS: Advertisements May Go to the Wrong Client If the .lkp File on the CAP Is Locked (326114)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
- Microsoft Systems Management Server 2.0 SP3
- Microsoft Systems Management Server 2.0 SP4
This article was previously published under Q326114 IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986 Description of the Microsoft Windows Registry SYMPTOMSMicrosoft Systems Management Server
(SMS) program advertisements may go to the wrong clients if any .lkp files on the client access point (CAP) are locked by a client. When an .lkp file is locked by a client, the file cannot be updated from the site server. For example, an advertisement for a group of computers may be incorrectly distributed to a group of users.
CAUSE
If any .lkp files on the CAP are inadvertently locked by clients for a long time, an .ins file name that was previously assigned to another collection resource may be generated again. This behavior may occur if several old advertisements are deleted and several new advertisements are created, because the random-name algorithm that is responsible for making sure that the targeted collection resources are uniquely identified by the .ins files on the CAP may inadvertently generate an .ins file name that was previously assigned to another collection resource. This causes the advertisement to be made available to the wrong resources.
RESOLUTION
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name Platform
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01-May-2002 20:10 2.0.1493.4190 827,664 Baseutil.dll Alpha
01-May-2002 17:10 2.0.1493.4154 179,984 Inboxmgr.dll Alpha
01-May-2002 20:10 2.0.1493.4190 537,536 Baseutil.dll x86
01-May-2002 17:10 2.0.1493.4154 112,016 Inboxmgr.dll x86
Note Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files. STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 4/14/2006 |
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Keywords: | kbQFE kbHotfixServer kbSMS200preSP5fix kbbug kbfix KB326114 |
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