Content Not Refreshed on Cluster Environment (326085)



The information in this article applies to:

  • Microsoft Content Management Server 2001 SP1

This article was previously published under Q326085

SYMPTOMS

In a Content Management Server (CMS) 2001 cluster environment, changes that are made to one of the servers do not propagate to the other servers in the cluster.

CAUSE

A timing issue in the CMS cache prevents the server from accurately determining the last time between changes.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Content Management Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version      Size     File name
   ------------------------------------------------------------------
   26-Jul-2002  11:33:49  4.0.942.402  1.08 MB  Aeserverobject.dll
				
NOTE: Because of file dependencies, this update requires Microsoft Content Management Server 2001 Service Pack 1.

WORKAROUND

Restart the servers in the cluster to flush the cache and reset the server times.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Content Management Server 2001.

MORE INFORMATION

Time on the CMS server for content refreshing is determined by using the server uptime counters. A limitation for the maximum number that can be retrieved from this counter prevents the server from accurately retrieving the server time after 25 days.

To check server uptime:
  1. Start Performance Monitor.
  2. Add the following counter:

    Performance Object = System
    Counter = System Up Time

  3. Convert the maximum value (reported in seconds) to days:

    If Max Value = 2,332,800
    2332800 s * (1 min / 60 s) = 38880 min
    38880 m * (60 min / 1 hr) = 648 hr
    648 hr * (24 hr / 1 day) = 27 days

2,332,800 seconds as the server uptime translates to 27 days uptime.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbContentMgtServ2001preSP2fix kbfix kbQFE KB326085