XADM: Replication Verification Tool (Replver.exe) Cannot Log On to Server (325928)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange Server 5.0
  • Microsoft Exchange Server 5.0 SP1
  • Microsoft Exchange Server 5.0 SP2
  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3
  • Microsoft Exchange Server 5.5 SP4
  • Microsoft Exchange Server 5.5 SP5

This article was previously published under Q325928
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

In the Replication Verification tool (Replver.exe), if you click Start on the Run menu, you receive the following error message:
IMAPISession::OpenMsgStore: Error: 8004011X
Logon failed for server Servername
Unable to logon to all servers. Aborting test
Tests done!

CAUSE

This issue occurs if the profiles for the two accounts that Replver.exe uses to access the folders are not or cannot be successfully created.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, follow these steps using the same account that you are using to run Replver:
  1. Create the MAPI profiles so that you can successfully access each of the two mailboxes (these are the two rv-servername profiles), and then log off the mail client.
  2. Start Registry Editor.
  3. Locate and then click the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\ Windows Messaging Subsystem\Profiles

    At least four profiles appear, including the two profiles that you created to access the mailboxes and the two that Replver tried to create. The two stub profiles that Replver tries to create use the following format:

    rv-organizationname_sitename_servername

    NOTE: If you do not have the two rv- stub profiles that Replver tries to create, you must reconfigure Replver by selecting the server name of the missing profile when you designate the master server in the topology map (you do not have to select the second server), and then run Replver.

  4. Click one of the mailbox profiles that you created in step 1 (rv-servername1).
  5. On the Registry menu, click Save Key to save the profile to your hard disk.
  6. Select the stub profile (rv-organizationname_sitename_servername1) for the profile in step 4 (rv-servername1).
  7. On the Registry menu, click Registry Restore, and then click the file that you saved in step 5.
  8. Click Yes to confirm the change.
  9. Repeat steps 4 through 8 for the other server's stub profile.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kberrmsg kbfile kbprb KB325928