Unknown Compression Filter Priority When You Turn On HTTP Compression (325927)



The information in this article applies to:

  • Microsoft Internet Information Services 5.0

This article was previously published under Q325927

SYMPTOMS

After you turn on compression for dynamic or static content, the compression filter priority shows the following status:
**Unknown**
No Event Viewer error messages provide any more details about why the priority is unknown or indicate whether the filter is currently working.

CAUSE

A minor error occurs in the priority status that causes the Internet Services Manager (ISM) user interface to show a status of "Unknown".

STATUS

Microsoft has confirmed that this is a problem in Internet Information Services 5.0.

MORE INFORMATION

After conclusive testing, Microsoft has determined that the compression filter is working as designed, even if the priority is reported as "Unknown". If you have turned on compression, you can verify that compression is working on the Internet Information Services (IIS) computer:

NOTE: The test in this example uses a page named Postinfo.html. This page comes with default installation of IIS and exists in the root of the Web site (if the page and the Web site exist). To reach the page, use the following URL, where localhost assumes that the test is being performed on the Web server:

http://localhost/postinfo.html

  1. Click Start, point to Programs, click Administrative Tools, and then open the Internet Services Manager.
  2. Right-click the server name, and then click Properties.
  3. In the Master Properties drop-down list, click to select WWW Services, and then click Edit.
  4. Click the Service tab. Under HTTP Compression, locate and confirm the temporary folder location (the default is %windir%\IIS Temporary Compressed Files).NOTE: If the priority is "Unknown", you cannot move the compression filter up or down in the order of filters.

  5. Open Microsoft Internet Explorer, and then type http://localhost/postinfo.html in the address bar to access the Postinfo.html page.
  6. Open Windows Explorer. To do this, click Start, point to Programs, click Accessories, and then click Windows Explorer.
  7. Locate and open the folder that you accessed in step 4.
  8. Locate a file that has a name such as $^~_gzip_d__inetpub_wwwroot_postinfo.

Steps to Reproduce the Behavior

  1. Turn on compression. For more information about how to do this, visit the following Microsoft Web site:
  2. Restart IIS.
  3. Open the WWW Services Master Properties in the ISM, and then view the filter priority under ISAPI Filters.

Modification Type:MinorLast Reviewed:7/16/2004
Keywords:kbpending kbprb KB325927