SMS: Nothing Appears in the Administrator Console If the Provider Is on a Separate Windows Server 2003 Server (325766)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q325766

SYMPTOMS

If the Systems Management Server (SMS) 2.0 provider is installed on a computer that is not the site server, and if the computer on which the provider is installed is running Microsoft Windows Server 2003, no data may appear for any nodes in the SMS Administrator console. For example, no collections appear when you click the Collections node.

CAUSE

The SMS provider is not handling the fully qualified domain name that Windows Management Instrumentation (WMI) returns in the Windows Server 2003 family.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239How to Obtain the Latest Systems Management Server 2.0 Service Pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-May-2002  12:55  2.0.1493.4115  562,960  Extnprov.dll  Alpha
   01-May-2002  12:55  2.0.1493.4115  290,784  Extnprov.dll  x86
				
The International Client Pack 1 (ICP1) version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-May-2002  12:55  2.0.1493.4115  562,960  Extnprov.dll  Alpha
   01-May-2002  12:55  2.0.1493.4115  290,784  Extnprov.dll  x86
				
The International Client Pack 4 (ICP4) version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   01-May-2002  12:55  2.0.1493.4115  562,960  Extnprov.dll  Alpha
   01-May-2002  12:55  2.0.1493.4115  290,784  Extnprov.dll  x86
				
NOTE: Because of file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

To Use the Hotfix Installer

NOTE: You can use this method only on I386-based computers.

Apply the Fix to the Site Server

  1. Copy the hotfix folder structure to a share on your network. Q325766.exe is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Log on to your site server by using an account with administrator permissions.
  3. On the site server, quit the SMS Administrator console.
  4. Run Q325766.exe and follow the instructions in the wizard. You can run the file in Quiet mode by using the /s switch.

Apply the Fix to the SMS Provider Server

  1. Copy the hotfix folder structure to a share on your network. Q325766.exe is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Log on to your site server by using an account with administrator permissions.
  3. On the computer on which the SMS provider is installed, quit the SMS Administrator console.
  4. Run Q325766.exe and follow the instructions in the wizard. You can run the file in Quiet mode by using the /s switch.

To Install the Hotfix Manually

Apply the Fix on the Site Server

  1. Quit the SMS Administrator console, and stop the Windows Management service and all other SMS services.
  2. Replace the Extnprov.dll file in the Sms_root_folder\Bin\Platform folder with the version from the hotfix.
  3. Restart the SMS services and the Windows Management service.

Apply the Fix to the SMS Provider Server

  1. Stop the SMS_SQL_MONITOR and Windows Management services.
  2. Replace the Extnprov.dll file in the Drive:\Smsprov\Bin\Platform folder with the version from the hotfix.
  3. Restart the SMS_SQL_MONITOR and Windows Management services.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbMiscTools kbSMS200preSP5fix kbBug kbfix KB325766