XADM: Exchange 2000 System Attendant Does Not Start--Error 1053 (325511)



The information in this article applies to:

  • Microsoft Exchange 2000 Server SP2
  • Microsoft Exchange 2000 Server SP3

This article was previously published under Q325511

SYMPTOMS

If you remove the third-party Veritas NetBackup program from an Exchange 2000 server that has Service Pack 2 (SP2) or later installed on it, the Exchange 2000 System Attendant service does not start after you restart the server. The following error is logged in the System Event log:

Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Description:
Application popup: exmgmt.exe - Unable To Locate DLL : The dynamic link library MSVCP60.dll could not be found in the specified path C:\Program Files\Exchsrvr\bin;C:\WINNT\system;C:\WINNT;C:\WINNT\system32;.

If you try to start the System Attendant service manually, you receive the error message:
Could not start the Microsoft Exchange System Attendant service on Local Computer.

Error 1053: The service did not respond to the start or control request in a timely fashion.

CAUSE

Veritas NetBackup software Setup has removed the Msvcp60.dll file from the %System32% folder on the Exchange 2000 server. Beginning with Exchange 2000 SP2, the System Attendant service depends on this file, and does not start successfully if it is missing.

NOTE: Other programs may also remove this file when you remove those programs from the Exchange 2000 server.

WORKAROUND

There are two workarounds for this problem:
  • Reinstall Exchange 2000 SP2 or later.

    -or-
  • Copy the Msvcp60.dll file from the Exchange 2000 SP2 CD or file share to the %System32% folder on the affected Exchange 2000 server, and then restart the server.
In both workarounds, make sure that you use the same service pack version as the version that is currently installed on the server. For example, if server has Exchange 2000 SP2 installed on it, use the Exchange 2000 SP2 CD to reinstall or copy the Msvcp60.dll file.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

MORE INFORMATION

This problem occurs when Exchange 2000 SP2 or later is installed because Setup does not properly increment the number of programs that are using the Msvcp60.dll file in the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs

During the removal process, the Veritas Setup program subtracts the count of programs that use this .dll file, and if the registry count reaches zero, the file is deleted from the hard disk because the zero count indicates to Setup that the file is not used by any other programs on the server. After you restart the server, if the system cannot find another copy of the Msvcp60.dll on the hard disk, the System Attendant service does not start.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbbug kbnofix KB325511