RPCSS OXIDResolver Pings Must Fall Back to Endpoint Mapper (325409)



The information in this article applies to:

  • Microsoft COM+ 1.0
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Professional SP3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1

This article was previously published under Q325409

SYMPTOMS

Currently, DCOM on a Win32 system cannot talk to DCOM on other systems, such as VMS.

CAUSE

On a Win32 system, the DCOM Service Control Manager (SCM) or resolver always listens on the same endpoint as the Remote Procedure Call (RPC) endpoint mapper (that is, port 135). On foreign systems like VMS, the DCOM SCM or resolver may listen on ports other than 135. When a Win32 DCOM system tries to connect to the foreign DCOM system by using RPC, it must take this into account. If a Win32 DCOM system cannot find the DCOM SCM interfaces on port 135, it must fall back to talk to the endpoint mapper on the foreign system and find the endpoint on which the foreign system listens. DCOM does not do this correctly for Object Exporter Identifier (OXID) pings.

RESOLUTION

To resolve this problem, obtain Microsoft COM+ Rollup Hotfix 22.

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

328924 INFO: Availability of Windows 2000 Post-Service Pack 3 COM+ Hotfix Rollup Package 22

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to Install Multiple Windows Updates or Hotfixes with Only One Reboot


Modification Type:MinorLast Reviewed:10/5/2005
Keywords:kbbug kbfix kbQFE kbWin2000preSP4Fix KB325409