FIX: Problems with HTTP Transport (325401)



The information in this article applies to:

  • Microsoft BizTalk Server 2002

This article was previously published under Q325401

SYMPTOMS

A BizTalk HTTP transport may be unsuccessful when the HTTP transport posts messages to the partner. The problem may cause duplicated messages to be sent to the partner and may cause messages to be moved to the suspended queue. The problem occurs if the HTTP 100 and HTTP 200 responses from the partner are in a single Transmission Control Protocol (TCP) packet.

CAUSE

BizTalk Server does not recognize the HTTP 200 response if the HTTP 100 and HTTP 200 responses are in a single TCP packet. This causes it to retransmit the message, which results in duplicated messages to the partner. If all responses from the partner during all retries of a message have the pattern of the HTTP 100 and HTTP 200 responses in a single TCP packet, BizTalk moves the message to the suspended queue.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

815781 How to Obtain the Latest BizTalk Server 2002 Service Pack

Hotfix Information


A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   -------------------------------------------------------
   26-Jun-2002  14:50  3.0.1525.0   528,656 Sharedcomp.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in Microsoft BizTalk Server 2002 Service Pack 1.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbBizTalk2002SP1fix kbbug kbfix KB325401