FIX: BizTalk Assumes "MIME-Version" Is the First Header of a MIME-Encoded Message (325171)



The information in this article applies to:

  • Microsoft BizTalk Server 2002

This article was previously published under Q325171

SYMPTOMS

If a Multipurpose Internet Mail Extensions (MIME)-encoded message does not have "MIME-Version" as the first header, BizTalk Server does not parse the data, and you receive the following error message:
An error occurred in BizTalk Server.

Details:
------------------------------
[0x1439] No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.

[0x1730] Suspended Queue ID: "{3336A3A3-72F6-4321-A1BD-E039B9776683}"

[0x0147] The business document that was passed in is not in a recognized format and could not be parsed or decrypted.

CAUSE

Because a MIME message that is encoded with Collaboration Data Objects (CDO) from Microsoft Office XP Service Pack 1 has "thread-index" as the first header, the BizTalk Server cannot parse the message.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

815781 How to Obtain the Latest BizTalk Server 2002 Service Pack

Hotfix Information


A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   -----------------------------------------------------------------
   12-Jul-2002  15:25  3.0.1524.0   348,432  Mscis.exe 
   12-Jul-2002  15:25  3.0.1524.0   131,344  Cisapi.dll
   12-Jul-2002  15:25  3.0.1524.0   524,560  Ciscore.dll
   12-Jul-2002  15:25  3.0.1524.0   405,776  Cisengine.dll
   11-Apr-2002  9:41                19,632   Sq_priorityupgrade.sql
   11-Apr-2002  9:41                13,680   Btm_priorityupgrade.sql
				
With this fix, BizTalk Server searches the first 1,200 bytes for the "MIME-Version" header.

This problem is resolved with the fix that is contained in this article. To install the fix, you must follow the instructions in the Readme text file that comes with the fix. This information is outlined as follows:

For each computer that is running BizTalk Server and for each database group, Btm_priorityupgrade.sql must be executed against the BizTalk Interchange_BTM database, and Sq_priorityupgrade.sql must be executed against the BizTalk Interchange_SQ database. To do this, you must use the SQL Query Analyzer to execute the stored procedures against the affected BizTalk database.

To install this fix, follow these steps:
  1. Use either the Services Microsoft Management Console (MMC) or the BizTalk Server Administrator to stop BizTalk Server. To use the Services MMC on Microsoft Windows 2000, follow these steps:

    1. Click Start, point to Settings, click Control Panel, and then double-click Administrative Tools.
    2. Click Services, double-click System services, and then double-click BizTalk Messaging Services to stop or restart the BizTalk Messaging Service.
    To use the Services MMC on Microsoft Windows XP, follow these steps:

    1. Click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.
    2. Double-click System services, and then double-click BizTalk Messaging Services to stop and restart the BizTalk Messaging Service.
    To use the BizTalk Server Administrator, right-click the BizTalk Server name in the BizTalk Server group to stop or start the services.

  2. In the BizTalk Server installation directory (\Program Files\Microsoft BizTalk Server\), delete Cisengine.dll, Ciscore.dll, and Mscis.exe.
  3. Replace the deleted files with the files from this fix.
  4. Use the SQL Query Analyzer to apply Btm_priorityupgrade.sql to the Interchange_BTM database.
  5. Use the SQL Query Analyzer to apply Sq_priorityupgrade.sql to the Interchange_SQ database.
  6. Use either the Services Microsoft Management Console (MMC) or the BizTalk Server Administrator to restart BizTalk Server.
NOTE: You must upgrade all servers that share the database. Any computers that are running BizTalk Server and that do not have the fix installed do not start after the BizTalk Management (BTM) and Shared Queue (SQ) databases have been updated. These two SQL database updates must be run before you run Hotfixsetup.exe. If they are not updated, the BizTalk Service does not start.


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in Microsoft BizTalk Server 2002 Service Pack 1.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbBizTalk2002SP1fix kbbug kbfix KB325171