FIX: COMTI Perfmon Counters Do Not Collect Data by Using Microsoft Operations Manager Client (325103)
The information in this article applies to:
- Microsoft Host Integration Server 2000
This article was previously published under Q325103 SYMPTOMS
When you try to view COM Transaction Integrator (COMTI) Performance
Monitor counters by using the Microsoft Operations Manager (MOM)
client, no data is collected and all of the counters show a value of
0.
The same problem can occur with Performance Monitor if your computer is
set up to start Performance Monitor before any of the COMTI
applications start.
CAUSE
If the shared memory that is used to store performance data was created
by a monitoring application such as the MOM client or Performance
Monitor, COMTI does not use the correct security attributes to gain
access to the shared memory.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Host Integration Server 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
328152 How to Obtain the Latest Host Integration Server 2000 Service Pack
The English version of this fix has the file attributes (or later) that
are listed in the following table. The dates and times for these files
are listed in coordinated universal time (UTC). When you view the file
information, it is converted to local time. To find the difference
between UTC and local time, use the Time Zone tab in the Date
and Time tool in Control Panel.
Date Time Version Size File name
--------------------------------------------------
24-Jun-2002 13:24 5.0.0.867 28,944 Comtiperf.dll
NOTE: Because of file dependencies, the most recent fix that
contains the preceding files may also contain additional files.
WORKAROUND
The problem described here does not occur if the COMTI applications
that you want to monitor start before the monitoring application
starts. However, because the MOM client starts during system
initialization, the problem always occurs because the COMTI
applications are not likely to be running before to the MOM client
starts.
If the monitoring application is Performance Monitor (or another
similar application), you can avoid the problem by doing one of the
following:
- Start Performance Monitor after you start the COMTI
applications that you want to monitor.
-or- - Configure the COMTI applications to run under a user account
that has Administrative rights.
STATUSMicrosoft has confirmed that this is a problem in Microsoft Host Integration Server 2000. This problem was first corrected in Host Integration Server 2000 Service Pack 1.MORE INFORMATION
On a computer that does not experience this problem, when you select
the COM Transaction Integrator performance object, a general COMTI
instance is listed, and an instance for each COMTI application that is
active is listed, also.
When the problem described here occurs, the general COMTI instance is
listed but no additional instances are created when COMTI applications
are running, so none of the COMTI applications can be monitored. The
general COMTI instance counters are not incremented when the problem
occurs.
Modification Type: | Minor | Last Reviewed: | 4/7/2005 |
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Keywords: | kbBug kbfix kbHostIntegServ2000preSP1fix kbHostIntegServ2000SP1fix KB325103 |
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