XADM: Error Message: The Account <Domain\User_Name> Is Not Recognized by the AutoDL System (324816)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q324816 SYMPTOMS
When a user tries to gain access to the AutoDL Web page, the user may receive an error message that is similar to:
The account domain\username is not recognized by the AutoDL System. If you feel that this is incorrect, please contact your local helpdesk, or visit http://your_company/helpdesk to create a service request.
If the user receives this error message on the AutoDL Web page, the user also receives following error message:
A runtime error has occurred. Do you wish to debug? Line 47 Error: Object required: "Metrics"
NOTE: If the user receives both of these error messages, the user receives these error messages regardless of the account that is used.
CAUSE
The error message is a generic error message that may have a number of causes.
RESOLUTION
To resolve this issue:
- Determine if your environment has a domain structure that includes a fully qualified domain name (FQDN) with two dots (for example, corp.contoso.com) with a different network basic input/output system (NetBIOS) name (for example, northamerica). This naming scheme (two dots in the FQDN and a different NetBIOS name) may cause this issue. To work around this issue if such a naming scheme is the cause, change the domain name.
In the sample environment, you can change the FQDN from corp.contoso.com to contoso.com and keep the NetBIOS name of northamerica. This naming scheme works correctly because there are no longer two dots in the FQDN. - If you determine that your domain environment does not have two dots in the FQDN and a different NetBIOS name, use the following resolutions. Perform these resolutions in the order listed. (They are listed by frequency of solution.)
In other words, resolution 1 most frequently fixes this issue. Follow all the steps in Resolution 1. If those steps resolve this issue, you are finished. If this issue still occurs after you follow the steps in resolution 1, follow the steps in resolution 2. After you finish following the steps in a resolution, stop and determine whether or not this issue is resolved. If this issue is not resolved, follow the steps in the next resolution:- Resolution 1:
- Start Microsoft SQL Enterprise Manager.
- Expand Microsoft SQL Servers, expand SQL Server Group, and then expand server_name. Expand Databases, expand AutoDL, and then expand Tables.
- Right-click DSDomains, click Open Table, and then click Return all rows.
- In the Name column, make sure that the NetBIOS name is specified, and not the FQDN.
- Resolution 2:
- Click Start, point to Programs, point to Administrative Tools, and then click Component Services.
- Expand Component Services, expand Computers, expand My Computer, and then expand COM+ Applications.
- Right-click AutoDL, and then click Properties.
- Click Identity.
- Change This application will run under the following account from Interactive user-the current logged on user to This user, and then specify the Administrator account.
- Stop and restart the AutoDL COM+ object.
- Resolution 3:
- Click Start, point to Programs, point to Administrative Tools, and then click Component Services.
- Expand Component Services, expand Computers, and then expand My Computer. Expand COM+ Applications, expand AutoDL, and then expand Components. Make sure that APSMisc.DataEngine.1 is present.
- Right-click APSMisc.DataEngine.1, click Properties, and then click the Security tab. Under Roles explicitly set for selected item(s), make sure that AutoDL_Everyone and AutoDL_Admins are both selected.
- Stop and restart the AutoDL COM+ object.
After you do so, determine whether this issue still occurs. If this issue does not occur, you are finished. If this issue still occurs, perform the next step (step 5). - Remove and add the COM+ object APSMisc.DataEngine.1(APSMisc.dll):
- Expand Component Services, expand Computers, and then expand My Computer. Expand COM+ Applications, expand AutoDL, and then expand Components.
- Right-click APSMisc.DataEngine.1, and then click Delete.
- Right-click Component, and then click Add.
- Locate the AutoDL\COM+ folder on your hard disk.
- Add APSMisc.dll.
- Right-click APSMisc.DataEngine.1, and then click Properties.
- Click the Security tab, and then add AutoDL_Everyone and AutoDL_Admins.
- Resolution 4:
- Click Start, point to Programs, point to Administrative Tools, and then click Component Services.
- Expand Component Services, expand Computers, and then expand My Computer. Expand COM+ Applications, expand AutoDL, and then expand Roles.
- Make sure that the user who is trying to access the AutoDL Web page is a member of either the AutoDL_Admins group or the AutoDL_Everyone group.
- Resolution 5:
- Click Start, point to Programs, point to Administrative Tools, and then click Data Sources(ODBC).
- Click System DN.
- Click Add.
- Create a new AutoDL object.
- When you are prompted to overwrite the existing file, click Yes.
- Make sure that you select the correct SQL Server, and then select AutoDL as the default database.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kberrmsg kbprb KB324816 |
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