New Client Installation Is Unsuccessful If the Data in the Copylog.tcf File Is Truncated or Removed (324771)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1
  • Microsoft Systems Management Server 2.0 SP2
  • Microsoft Systems Management Server 2.0 SP3
  • Microsoft Systems Management Server 2.0 SP4

This article was previously published under Q324771

SYMPTOMS

When you try to install new Systems Management Server (SMS) 2.0 clients, they may not install successfully, and the system may also start to remove existing clients.

CAUSE

This problem occurs if the data in the Copylog.tcf file on the SMS logon point is truncated or removed. Truncation or removal of the Copylog.tcf data occurs when the file is locked by another process, such as the client installation process.

RESOLUTION

To resolve this problem, obtain the latest service pack for Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to Obtain the Latest Systems Management

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jul-2002  18:44  2.0.3.1           272,649  Q324771.exe	Post SP3
   24-Sep-2002  16:46  2.0.4.1           252,620  Q324771.exe	Post SP4

After the post-Service Pack 3 (SP3) hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   02-Mar-2001  03:15  2.0.1493.3275   1,514,768  Baseobj.dll Alpha
   02-Mar-2001  03:15  2.0.1493.3275     965,728  Baseobj.dll X86
After the post-Service Pack 4 (SP4) hotfix is installed, the following files will have the listed attributes or later:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   01-May-2002  14:40  2.0.1493.4136   1,514,768  Baseobj.dll Alpha
   01-May-2002  14:40  2.0.1493.4136     965,728  Baseobj.dll X86 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:4/14/2006
Keywords:kbQFE kbHotfixServer kbbug kbfix KB324771