"Spooler subsystem app has encountered a problem and needs to close" and "Operation could not be completed" error messages (324757)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

This article was previously published under Q324757
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You may experience either of the following symptoms on your Microsoft Windows XP-based computer:
  • When you start your computer, when you try to start the PrintSpooler service, when you try to stop the Print Spooler service, or when you click Start, and then click Printers and Faxes, you may receive the following error message:
    Spooler subsystem app has encountered a problem and needs to close.
  • When you click Start, and then click Printers and Faxes to try to view your printers, no printers appear even though you have a printer installed. If you click Add a printer, or if you try to print, you may receive the following error message:
    Operation could not be completed.
    As a result, you cannot add a printer.

CAUSE

This issue may occur if a third-party printer driver or a third-party service that is installed prevents you from adding printers, or if the third-party printer driver or the third-party service affects the functionality of a newly installed printer.

For example, this issue may occur if the Lexmark print service (LexBce Server service) is installed and is running on your computer before you try to add another printer.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, follow these steps:
  1. If the Lexmark print service is installed on your computer, turn off the LexBce Server service. To do this, follow these steps:
    1. Click Start, right-click My Computer, and then click Manage.
    2. Expand Services and Applications, and then click Services.
    3. In the right pane, right-click LexBce Server, and then click Properties.
    4. On the General tab, in the Startup type list, click Disabled.
    5. Under Service status, click Stop, and then click OK.
    6. Right-click the Print Spooler service, and then click Start (if it is stopped).
    7. Quit Computer Management.

  2. Test whether the issue is resolved. If the issue is resolved, you do not have to follow the remaining steps. If the issue is not resolved, go to step 3, and then follow the remaining steps.
  3. Start the computer in Safe Mode.

    For additional information about how to start your computer in Safe Mode, click Start, click Help and Support, type safe mode in the Search box, press the ENTER key, and then click the Start Windows in Safe Mode topic.
  4. Start Microsoft Windows Explorer, and then delete all the files and the folders in the following two folders (where C: is the drive where you have Windows XP installed):
    • C:\Windows\System32\Spool\Printers
    • C:\Windows\System32\Spool\Drivers\w32x86
  5. Start Registry Editor. To do this, click Start, click Run, type regedit in the Open box, and then click OK.
  6. Locate and expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86

    View the list of subkeys. There should only be the following subkeys:
    • Drivers
    • Print Processors
  7. If there are any subkeys other than the subkeys that are listed in step 6, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type a descriptive name for this key, and then click Save--for example, type WindowsNTx86regkey.

      You can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86 registry key to restore the key if you experience any issues after you complete this procedure.
    3. Delete all the subkeys other than the subkeys that are listed in step 6. To do this, right-click each subkey that is not on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.
  8. Locate and then expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers

    The registry entries for the printer drivers that are installed on the computer are stored in the Version-x subkey or subkeys, where x is a number (typically 2 or 3).
  9. Expand the Version-x subkey or subkeys, and then delete the printer driver entries. To do this, right-click each printer driver subkey, and then click Delete. Click Yes when you are prompted to confirm the deletion.
  10. Locate and then expand the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

    View the list of subkeys. There should only be the following subkeys for the default print monitors:
    • BJ Language Monitor
    • Local Port
    • PJL Language Monitor
    • Standard TCP/IP Port
    • USB Monitor
  11. If there are any subkeys other than the subkeys that are listed in step 10, follow these steps:
    1. On the File menu, click Export.
    2. In the File Name box, type a descriptive name for this key -- for example, type MonitorsRegkey, and then click Save.

      You can use this backup of the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key to restore the key if you experience any issues after you complete this procedure.
    3. Delete all the subkeys other than the subkeys that are listed in step 10. To do this, right-click each subkey that is not on the list, and then click Delete. Click Yes when you are prompted to confirm the deletion.
  12. If you have a local printer attached, disconnect the printer cable from the computer, and then restart the computer.
  13. Verify that the Print Spooler service is running. To do this, follow these steps:
    1. Click Start, right-click My Computer, and then click Manage.
    2. Expand Services and Applications, and then click Services.
    3. In the right pane, right-click the Print Spooler service, and then click Start (if it is stopped).
    4. Quit Computer Management.
  14. If you have a local printer attached, reconnect the printer cable to the computer, add the printer that you want, and then try to print a test page. To add your printer, follow these steps:
    1. Click Start, and then click Printers and Faxes.
    2. Click Add a printer.

      The Add Printer Wizard starts.
    3. Follow the instructions in the Add Printer Wizard to install the printer that you want.

MORE INFORMATION

For more information about how to manually remove printer drivers, click the following article number to view the article in the Microsoft Knowledge Base:

135406 Steps to manually remove and reinstall a printer driver

For more information about how to troubleshoot printing problems in Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:

314085 Troubleshooting general printing problems in Windows XP

308028 Resources for troubleshooting printing problems in Windows XP

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:7/29/2005
Keywords:kbRegistry kb3rdparty kbenv kbprint kbDriver kberrmsg kbprb KB324757 kbAudEndUser