OFFXP: "Internal Error 2352" Error Message When You Try to Install Office XP (324660)



The information in this article applies to:

  • Microsoft Office XP (Setup), when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows Millennium Edition

This article was previously published under Q324660

SYMPTOMS

When you try to install Office XP or any Office XP program, you may receive an error message similar to one of the following:
Internal error: 2352 Couldn't initialize cabinet file server.
The required file 'Cabinet.dll' may be missing.

-or-

Internal error 2352. Please contact Product Support.

CAUSE

This problem may occur if the Cabinet.dll file is missing or damaged.

RESOLUTION

To resolve this problem, install or replace the Cabinet.dll file. To do this, follow this six-part procedure.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Part 1: Rename the Damaged Cabinet.dll File

  1. Click Start, and then click Search.
  2. Click All files and folders.
  3. In the All or part of the file name box, type cabinet.dll.
  4. In the Look in box, click the root of the hard disk (typically, C:), and then click Search.
  5. Right-click Cabinet.dll (if it is found), click Rename, type cabinet.old, and then press ENTER.

Part 2: Restart Your Computer Using a Clean Boot

Start Windows by loading a minimal set of drivers and services. This process, also known as a clean boot, provides as "clean" an installation environment as possible in which to reinstall a program. To perform a clean boot, follow these steps.

NOTES:

The following steps apply to Windows XP only. For more information about how to use a clean boot in Windows XP and earlier, see the "More Information" section later in this article.

You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup, and then click to clear the following check boxes:

    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items

    You cannot clear the Use Original BOOT.INI check box.
  3. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  4. Click OK, and then click Restart to restart your computer.

Part 3: Install Windows Installer

  1. Insert the Office XP CD in your CD-ROM or DVD-ROM drive. Hold down the SHIFT key to prevent the program from starting automatically.
  2. Right-click Start, and then click Explore.
  3. Locate and then double-click the MSI folder on this CD.
  4. Double-click Instmsia.exe to run it.

Part 4: Extract the Cabinet.dll File

To extract the Cabinet.dll file from the Windows CD, use one of the following procedures, as appropriate for your operating system. For additional information about how to use System File Checker to extract a file, click the article number below to view the article in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

Windows XP

  1. Start Microsoft Windows Explorer.
  2. Copy the Extract.exe file from the System folder of your Microsoft Office CD1 to the Desktop folder on your computer.
  3. Click Start, and then click Run.
  4. In the Open box, type cmd, and then press ENTER.
  5. At the command prompt, type the following

    extract drive:\Extract.exe

    and then press ENTER, where drive is your CD-ROM drive or DVD-ROM drive.
  6. After the file is extracted, type exit at the command prompt, and then press ENTER.

Microsoft Windows 98 or Microsoft Windows 98 Second Edition (SE)

  1. Click Start, and then click Run.
  2. In the Open box, type sfc, and then click OK.
  3. Click Extract one file from installation disk.
  4. In the Specify the system file you would like to restore box, type cabinet.dll, and then click Start.
  5. In the Restore from box, type drive:\win98, where drive is the CD-ROM or DVD-ROM drive that contains your Windows CD.
  6. In the Save file in box, type drive:\windows\system, where drive is the drive on which Windows is installed, and windows is the folder in which Windows is installed, and then click OK.
  7. Click OK.
  8. Click OK when the file has been successfully extracted.

Microsoft Windows Millennium Edition (Me)

  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. Click Extract File.
  4. In the Specify the system file you would like to restore box, type cabinet.dll, and then click Start.
  5. In the Restore From box, type the path to your Windows Cab file. (For example, type c:\windows\options\install, or drive:\win9X, where drive is the CD-ROM or DVD-ROM drive that contains your Windows CD.)
  6. In the Save file in box, type drive:\windows\system, where drive is the drive on which Windows is installed, and windows is the folder in which Windows is installed, and then click OK.
  7. Click OK, and then continue with the restore function.

Part 5: Install Office

  1. Click Start, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. In the left pane, click Add New Programs.
  4. Click CD or Floppy.
  5. Follow the on-screen instructions to complete the installation process.

Part 6: Return from a Clean Boot State

NOTE: This procedure applies to Windows XP only. For more information about how to return from a clean boot state in Windows XP and earlier, see the "More Information" section of this article.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Normal Startup - load all device drivers and services.
  3. Click OK. Click Restart when you are prompted to restart your computer.

MORE INFORMATION

For additional information about how to perform a clean boot, click the article numbers below to view the articles in the Microsoft Knowledge Base:

310353 How to Perform a Clean Boot in Windows XP

316434 HOW TO: Perform Advanced Clean-Boot Troubleshooting in Windows XP

267288 How to Perform a Clean Boot in Windows Millennium Edition

192926 How to Perform Clean-Boot Troubleshooting for Windows 98


Modification Type:MinorLast Reviewed:1/6/2006
Keywords:kberrmsg kbprb KB324660