"Please point setup to the path 510581.Winword.msp" error message when you repair, remove, or reinstall an Office program or add a new component (324637)



The information in this article applies to:

  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q324637
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to repair, remove, or reinstall an Office XP program or add a new component, you may receive an error message similar to one of the following:
Please point setup to the path 510581.Winword.msp.

-or-

The feature you are trying to use is on a network resource.

CAUSE

This behavior may occur if an update file (patch) is corrupted or was deleted.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following key in the registry:

    \HKEY_CURRENT_USER\Software\Microsoft\Installer\Patches

  3. On the Registry menu, click Export Registry File, type Patches1 in the File name box, and then click Save.
  4. Right-click the key, click Delete, and then click Yes.
  5. Locate and then expand the following key in the registry:

    \HKEY_CURRENT_USER\Software\Microsoft\Installer\Products

  6. Click each subkey in the Products key until you find one with the entry ProductName whose value is the name of the Office program that you are trying to install, remove, repair, or reinstall. For example

    \HKEY_CURRENT_USER\Software\Microsoft\Installer\Products\GUID\ProductName = "Microsoft Office XP"

    where GUID is the globally unique identifier.

    If none of the subkeys contain this entry, go to step 9.
  7. With the subkey selected, click Export Registry File on the Registry menu, type Patches2 in the File name box, and then click Save.
  8. Right-click the subkey, click Delete, and then click Yes.
  9. Quit Registry Editor.

REFERENCES

For additional information about troubleshooting setup problems, click the following article number to view the article in the Microsoft Knowledge Base:

308490 How To Troubleshoot an Update Installation by Using Log Files in Office XP


Modification Type:MinorLast Reviewed:2/16/2006
Keywords:kbRegistry kbtshoot kberrmsg kbprb KB324637