Incorrect cipher strength appears in Security Information dialog box (324522)



The information in this article applies to:

  • Microsoft Outlook 2000, Service Release 1 (SR-1)

This article was previously published under Q324522

SYMPTOMS

In Outlook 2000, when you click About Microsoft Outlook on the Help menu, and then click Security Info, the cipher strength information may appear as 40-bit although you updated Outlook 2000 to use 128-bit security encryption.

CAUSE

This issue may occur if you upgraded to Outlook 2000 from an earlier version of Outlook that used 128-bit encryption.

RESOLUTION

To resolve this issue, rename the Exchcsp.dll file on your hard disk, download, and then install the 128-Bit Encryption Provider for Outlook 2000 SR-1 Update. To do so, follow these steps:
  1. Quit Outlook 2000.
  2. Start Windows Explorer, and then locate the following folder where drive is the drive on which Windows is installed:

    drive:\Program Files\Common Files\System\Mapi

  3. Right-click the Exchcsp.dll file, and then click Rename.
  4. Type Exchcsp.old, and then press ENTER.
  5. Install the 128-Bit Encryption Provider for Outlook 2000 SR-1 Update.

    To download this update, visit the following Microsoft Web site:
  6. Start Outlook 2000.
  7. Verify that the update installed successfully, and that the cipher strength information appears correctly as 128 bits. To do so, on the Help menu, click About Microsoft Outlook, and then click Security Info.

MORE INFORMATION

For additional information about how to use Outlook 2000 with 128-bit encryption, click the following article number to view the article in the Microsoft Knowledge Base:

202181 Using Outlook with 128-bit encryption version


Modification Type:MajorLast Reviewed:9/24/2004
Keywords:kbdownload kbprb KB324522