FIX: SAK System Stop May Occur with Large Data Volumes After Restore (324159)



The information in this article applies to:

  • Microsoft Server Appliance Kit (SAK), version 2.0

This article was previously published under Q324159

SYMPTOMS

A SAK system may stop after you reinstall both the operating system (OS) and the Storage Manager if the Storage Manager is already installed.

CAUSE

The Name Server driver (NmSvFsf.sys) is a companion to the driver QAFilter.sys. The Name Server driver is used to cache filenames in the I/O to speed the processing of the quota information.

The problem that is described in this article describes a "race" condition in NmSvFsf.sys. NmSvFsf.sys initiates the look-aside list two times, and this causes a loop in the system-wide look-aside list. The next time the system reads the system-wide look-aside list, the system holds a spin lock, which prevents the completion of any I/O by the small computer system interface (SCSI) driver. NmSvFsf.sys has been corrected so that it only reads the look-aside list one time.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Server Appliance Kit that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Version    Size      File name     Platform
   -----------------------------------------------------------------
   Jul-08-2002  05:52p              370       Info.INF      x86
   Mar-04-2002  03:18p              4,157,541 Q324159.exe   x86
				

STATUS

This problem that is described in this article has been resolved. You can correct this problem if you install the software update, Q324159.cab, through the Server Appliance Kit.

MORE INFORMATION

Follow these steps to install the software update:
  1. On the main Server Appliance Kit window, click the Maintenance tab.
  2. Click Software Update.

    The Welcome window appears.
  3. Click Next to continue.
  4. On Select File window, click Browse, and then click to select the Q324159.cab file.
  5. Click Verify and then click Next to continue.
  6. Click Finish to install the Q324159.cab file.

Modification Type:MinorLast Reviewed:10/12/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB324159