Dungeon Siege: "Has encountered a problem and needs to close" error message when you try to connect by using the ZoneMatch server (323953)



The information in this article applies to:

  • Microsoft Dungeon Siege 1.0

This article was previously published under Q323953

SYMPTOMS

When you try to connect to a multiplayer game of Microsoft Dungeon Siege 1.0 by using the ZoneMatch server, you may receive an error message that is similar to the following:
Microsoft Dungeon Siege has encountered a problem and needs to close. We are sorry for the inconvenience.
If you click Click Here, the following log appears:
AppName: dungeonsiege.exe
AppVer: 0.2.3.801
ModName: newdot~1.dll
ModVer: 3.0.0.70
Offset: 0000ee14

CAUSE

This problem will only occur if the third-party product New.net client software version 2.109 (released July 2, 2001) is installed on your computer. This problem was fixed in the New.net client software version 3.10 (released July 11, 2001). This problem does not occur with any versions of the New.net client software released on or after July 11, 2001.

RESOLUTION

To resolve this problem, update your version of the New.net client software. To do this, visit the following New.net Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.
Click the Enable Your Browser to see New.net Domains link in the upper-right corner of the page. Alternatively, you can also remove the New.net client software. To do this, visit the following New.net Web site, and then follow the removal instructions that are listed: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbnetwork kberrmsg kbprb KB323953