"Zoo Tycoon Has Encountered a Problem" Error Message or Game Quits When You Start a Dinosaur Digs Game (323943)



The information in this article applies to:

  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack

This article was previously published under Q323943

SYMPTOMS

When you start a Dinosaur Digs game, you may expience either of the following:
  • You receive the following error message:
    Zoo Tycoon has encountered a problem and needs to close. We are sorry for the inconvenience.

    To see what data this error report contains, click here.
    When you view the data in the error report, the report contains an error signature similar to the following:
       AppName     AppVer       ModName     ModVer       Offset  
       zoo.exe     11.5.0.6     zoo.exe     11.5.0.6     001307a2
    				
  • The game quits unexpectedly.

CAUSE

This issue may occur if terrain blending is turned on, or if the video driver for your video adapter is outdated.

This issue is known to occur on computers with AMD K6-2-based processors. Computers with AMD K6-2-based processors may not be able to use the terrain blending feature.

RESOLUTION

To troubleshoot and resolve this issue, use the following methods, in the order in which they are presented.

Method 1

Turn off terrain blending. To do so, follow these steps:
  1. Start Zoo Tycoon Dinosaur Digs, and then click Play Freeform Game.
  2. In the Map List, click a Zoo Tycoon map (for example, click Basic Grass Map (Small)), and then click Play.

    Note In this step, make sure that you select a Zoo Tycoon map and not a Dinosaur Digs map.
  3. Click the Game Options button.
  4. Click the Sound & Video tab.

    This tab is located directly below the File Options tab on the right side of the Game Options dialog box.)
  5. Under Terrain Blending, click Don't Blend, and then click the File Options tab.
  6. Click Main Menu, and then click No when you are prompted to save your current zoo.
  7. Start a Dinosaur Digs game and test whether the issue is resolved. If this procedure resolves the issue, you do not have to follow the remaining steps in this article. If the issue is not resolved, go to Method 2.
If you cannot start Zoo Tycoon Dinosaur Digs, you can turn off terrain blending by editing the Zoo.ini file. To do so, follow these steps:

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to All Programs, point to Accessories, and then click Notepad.
  2. On the File menu, click Open.
  3. In the Files of type box, click All Files, in the Look in box, locate the drive:\Program Files\Microsoft Games\Zoo Tycoon folder, where drive is the drive on which Windows is installed.
  4. Locate the Zoo.ini file, click the Zoo.ini file, and then click Open.
  5. Locate the following lines in the [advanced] section of the Zoo.ini file, where nis a number:

    drag=n
    click=n
    normal=n
    level=n

  6. Change the values for each of the following lines that you located in step 5 to 0. For example:

    drag=0
    click=0
    normal=0
    level=0

  7. Click Save on the File menu, and then quit Notepad.

Method 2

Update the video driver for your video adapter, and then remove and reinstall Zoo Tycoon and Dinosaur Digs. To do so, follow these steps.

Step 1: Update the Video Driver

Contact your video hardware manufacturer to obtain and install the latest version of the driver for your video adapter. For information about how to contact the manufacturer of your video adapter, see the "More Information" section of this article. To see if applicable driver updates are available, visit the following Microsoft Windows Update Web site: To identify the name and manufacturer of your video adapter, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type dxdiag, and then click OK.
  3. Click the Display tab.
  4. Under Device, look for Name and Manufacturer.

    Click Exit.

Step 2: Remove Zoo Tycoon and Dinosaur Digs

After you update the video driver, remove Zoo Tycoon and Dinosaur Digs. To do so, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the Currently installed programs list, click Zoo Tycoon - Dinosaur Digs, and then click Change/Remove.
  4. Click Uninstall, and then click OK.
  5. Click OK when you receive the message that states that Zoo Tycoon Dinosaur Digs was removed successfully.
  6. Click Start, and then click Search.
  7. In the All or part of the file name box, type zoo tycoon.
  8. In the Look in box, click the drive on which Zoo Tycoon was installed, and then click Search.
  9. In the search results window, right-click the Zoo Tycoon folder, and then click Delete.

    Click Yes to confirm the deletion.

Step 3: Restart the Computer by Using a Clean Boot Procedure

When you start Microsoft Windows, typically there are a number of programs that start automatically and run in the background that may interfere with the game. These programs may include antivirus and system utility programs. When you perform a clean boot, you prevent these programs from starting automatically. You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To restart your computer by using a clean boot procedure, follow these steps when you are using Windows XP.

Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality, but may result in the return of the original error message or behavior.
  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. On the General tab, click Selective Startup.
  4. Under Selective Startup, click to clear the following check boxes:
    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items
  5. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  6. Click OK, and then click Restart.
Click the Play button to view this streaming media demonstration.

For additional information or to view steps for other operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

331796 Games: How to Perform a Clean Boot to Prevent Background Programs from Interfering with Game Play

After you perform a clean boot, empty the temp folder in Windows. To do this, use the method that is appropriate for your system.

Windows XP or Windows 2000

Note The temporary folder is located in each specific user folder (for example, C:\Documents and Settings\user name\Local Settings\Temp). To empty the Windows temporary folder, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type %temp%, and then click OK.
  3. On the Edit menu, click Select All.
  4. On the File menu, click Delete.
  5. Click Yes when you receive the following message: Are you sure you want to send these items to the Recycle Bin?
  6. Test your game.

Windows 98 or Windows Millennium Edition (Me)

To empty the Windows temporary folder, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type temp, and then click OK.
  3. On the Edit menu, click Select All.
  4. On the File menu, click Delete.
  5. Click Yes to the following message: Are you sure you want to send these items to the Recycle Bin?
  6. Test your game.

Step 4: Reinstall Dinosaur Digs

To reinstall the Dinosaur Digs Expansion Pack, follow these steps:
  1. Insert the Zoo Tycoon Dinosaur Digs Expansion Pack CD-ROM into the CD-ROM drive or DVD-ROM drive.

    If Setup does not start automatically, follow these steps:
    1. Click Start, and then click Run.
    2. In the Open box, type the following line, where cd-rom is the drive letter of the CD-ROM or DVD-ROM drive.

      cd-rom:\setup.exe

    3. Click OK.
  2. Follow the on-screen instructions to install Dinosaur Digs.

Step 5: Restore the Computer to a Normal Startup

To restore the computer to use a normal startup, follow these steps:
  1. Start the System Configuration Utility. To do so, do one of the following, as appropriate to your operating system:
    • In Windows XP and Windows Me, click Start, and then click Run.

      Type msconfig in the Open box, and then click OK.
    • In Windows 98, click Start, point to Programs, point to Accessories, point to System Tools, and then click System Information.

      On the Tools menu, click System Configuration Utility.
  2. Click the General tab, click Normal Startup, and then click OK.
  3. Restart the computer.

MORE INFORMATION

For additional information about how to perform a clean-boot in Windows, click the article numbers below to view the articles in the Microsoft Knowledge Base:

310353 How to Perform a Clean Boot in Windows XP

267288 How to Perform a Clean Boot in Windows Millennium Edition

192926 How to Perform Clean-Boot Troubleshooting for Windows 98

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

For information about how to contact your video adapter manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z


Modification Type:MajorLast Reviewed:8/2/2006
Keywords:kbhowto kbArtTypeSHOWME kbprb KB323943