Deleted text may no longer be marked as strikethrough when you open a Word 97 or a Word 2002 document that contains tracked changes after you have upgraded to Office XP from Office 97 (323883)



The information in this article applies to:

  • Microsoft Office 97 for Windows
  • Microsoft Word 2002
  • Microsoft Word 97 for Windows
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002

This article was previously published under Q323883
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you open a Microsoft Word 97 or a Microsoft Word 2002 document that contains tracked changes after you have upgraded to Microsoft Office XP by installing over Microsoft Office 97, deleted text may no longer be marked as strikethrough.

To experience this behavior, make sure that the "Use balloons in Print and Web Layout" feature is turned off. To do this, click Tools, click Options, click the Track Changes tab, and then click to clear the Use balloons in Print and Web Layout check box.

CAUSE

This behavior occurs because the "deleted text mark" setting, which is stored as a per-user registry setting, is not correctly migrated.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 OFFXP: How to Obtain the Latest Office XP Service Pack

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel:

Date           Time   Size       File name
---------------------------------------------------
11-Jun-2002   02:18     51,809   DoPatch.log
12-Jun-2002   04:25      1,804   Hotfix.txt
11-Jun-2002   02:01      2,847   Readme.txt
11-Jun-2002   02:18   5,629,440  Winword_admin.msp
					
Date           Time  Version         Size       File name
----------------------------------------------------------
22-May-2002   15:11  10.0.4115.0    10,170,368  Winword.exe
					


WORKAROUND

To work around this problem, use either of the following methods, as appropriate to your circumstances:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


  • Delete the data key.
  • Create a template to run the following line at startup

    Application.Options.DeletedTextMark = wdDeletedTextMarkStrikeThrough

    and then put it in the Startup folder. To do this, follow these steps:

    1. Start Word 2002.
    2. Press ALT+F11 to start the Visual Basic Editor.
    3. In the Project pane, expand Project (Document1).
    4. Expand the Microsoft Word object.
    5. Double-click ThisDocument.
    6. In the code pane, type the following:

      Sub Auto_Open() Application.Options.DeletedTextMark = wdDeletedTextMarkStrikeThrough End Sub

    7. Press ALT+F11 to return to Word.
    8. On the File menu, click Save As.
    9. In the Save as Type list, click Document Template (*.dot).
    10. In the Save in list, select the drive where Office is installed (typically drive C), and then locate the following folder:

      drive:\Program Files\Microsoft Office\Office10\Startup

    11. In the File Name box, type the following file name, and then click Save:

      wdFixStrikethrough.dot

    12. Quit and then restart Word.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office XP Service Pack 2 (SP-2).

Modification Type:MinorLast Reviewed:2/21/2006
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOfficeXPPreSP2fix kbOfficeXPsp2fix kbQFE KB323883