Error Message When You Access a USB Storage Device After Resuming from Suspend (323754)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP2
This article was previously published under Q323754 SYMPTOMS
If you try to use a Universal Serial Bus (USB) storage device immediately after you resume your computer from suspend, you may receive the following error message:
X:\ drive is not accessible. The request could not be performed because of an I/O device error.
You continue to receive the error message when you try to use the USB storage device until you either remove and reattach the device, or you restart the computer. This problem may occur with any USB storage device such as floppy disk drives, hard disks, or CD-ROM drives.
CAUSE
This problem occurs with some USB 1.x storage devices that are attached to a USB 2.0 controller in Windows 2000 with the USB 2.0 update installed.
RESOLUTION
To resolve this problem, obtain and install the updated Usbhub.sys file from the hotfix that is described in the following Microsoft Knowledge Base article:
306455 Your Computer May Stop Responding When Resuming from Standby
WORKAROUND
To work around this problem, wait approximately 10 seconds after you resume your computer before you try to use the USB 1.x storage device.
If you do not use any USB 2.0 devices on the computer, another workaround is to turn off the USB 2.0 controller in Device Manager. After you turn off the USB 2.0 controller, the problem that is described earlier in this article with USB 1.x devices does not occur.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 12/3/2003 |
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Keywords: | kbbug kbfix kbWin2000PreSP3Fix KB323754 |
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