Add/Remove Programs dialog box does not appear or is corrupted (323496)
The information in this article applies to:
- Microsoft Small Business Server 2000, when used with:
- the operating system: Microsoft Windows 2000
This article was previously published under Q323496 SYMPTOMS
When you try to start the Add/Remove Programs tool, a corrupted dialog box that contains a Cl&ose button may appear or the dialog box may not appear at all. You cannot start the Add/Remove Programs tool either from Control Panel or by running the Appwiz.cpl command-line tool and no errors are reported. If you open Help, a blank window appears on the right side of the dialog box.
CAUSE
This problem may occur if any of the following conditions are true:
- Appwiz.cpl and Mshtml.dll are no longer registered.
- The file permissions for Appwiz.cpl and Mshtml.dll are not correct.
- You are using an incorrect version of the Appwiz.cpl file and the Mshtml.dll file.
RESOLUTION
To resolve this problem, locate the Mshtml.dll file, and then verify that it is the correct version, date, and size. Additionally, verify that its permissions have not been changed. To do so:
- Locate the Mshtml.dll file in the Winnt\System32 folder.
- Verify that the version, date, and size of the Mshtml.dll file match the values that are described in the following table:
|
| SBS2000 STD | 5.0.3103.1000 | 26-Jul-00 | 2.23 MB | | SBS2000 Windows 2000 SP2 | 5.0.3502.4856 | 06-Mar-02 | 2.24 MB | | SBS2000 SP1 | 5.0.3502.5390 | 31-Jul-02 | 2.23 MB |
- Verify that permissions of the Mshtml.dll file match the permissions that are described in the following table:
|
| Administrators | Full Control | | Authenticated Users | Read and Execute, Read | | Server Operators | Modify, Read and Execute, Read, and Write | | Everyone | Read and Execute, Read | | System | Full Control |
- Verify that this file is the only copy of the Mshtml.dll file on the computer (not including the DLLCache copy).
- If the Mshtml.dll file has the correct version, date, size, and permissions, type the following commands at a command prompt, and then press ENTER after each command:
- regsvr32 /u c:\winnt\system32\appwiz.cpl
- regsvr32 /u c:\winnt\system32\mshtml.dll
- regsvr32 /u "c:\program files\common files\system\ole db\oledb32.dll" (including the quotation marks)
- regsvr32 c:\winnt\system32\appwiz.cpl
- regsvr32 c:\winnt\system32\mshtml.dll
- regsvr32 "c:\program files\common files\system\ole db\oledb32.dll" (including the quotation marks)
- If the behavior continues to occur, repair or reinstall the latest version of Microsoft Internet Explorer.
For additional information about how to repair or reinstall the latest version of Internet Explorer, click the following article numbers to view the articles in the Microsoft Knowledge Base:
217344
How to uninstall Internet Explorer 5
293907 How to uninstall Internet Explorer 6
STATUSMicrosoft is researching this problem and will post more information in this article when the information becomes available.
| Modification Type: | Minor | Last Reviewed: | 10/5/2004 |
|---|
| Keywords: | kbprb KB323496 |
|---|
|