Full-Text Queries Using Adobe PDF IFilter Do Not Return Any Search Results (323324)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001 SP1

This article was previously published under Q323324

SYMPTOMS

After you install Microsoft SharePoint Portal Server Service Pack 1 (SP1) on a computer where Microsoft SQL Server 2000 Service Pack 1 (SP1) is also installed, you may find that you cannot perform full-text searches by using Adobe PDF IFilter 5.0. When you search for text in Adobe .pdf documents, no results are returned.

CAUSE

This problem occurs because, when you install SharePoint Portal Server SP1, you update the Microsoft Search service (MSSearch) from the version in SQL Server 2000 SP1 to the version that is included in SharePoint Portal Server SP1. The version of MSSearch that is in SharePoint Portal Server SP1 uses an error code convention when MSSearch processes the single-threaded Adobe PDF IFilter that is not used by the version of MSSearch that is in SQL Server 2000 SP1.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   07-May-2002  17:32  2000.80.622.0     184,908  Sqlfth75.dll     
   11-May-2002  03:26  10.145.4629.21  1,589,248  Tquery.dll       
Note Because of file dependencies, this hotfix requires SharePoint Portal Server 2001 Service Pack 1 (SP1) and SQL Server 2000 Service Pack 2 (SP2) or later.

Important You must install SQL Server 2000 Service Pack 2 (SP2) or later before you install this hotfix. For additional information about how to obtain the latest SQL Server 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

290211 INF: How to Obtain the Latest SQL Server 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB323324 kbAudITPRO