You Cannot Restore the SharePoint Portal Server Data from Backup (323320)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q323320

SYMPTOMS

When you try to restore the SharePoint Portal Server data from backup, you may receive the following error message:
Error: An error occurred during restore. See the event log for more details.
ErrNo: 80040D97
Desc: Automation error
Source: MSDMBack

CAUSE

This problem may occur if the SharePoint Portal Server data has been relocated from the default path, and the drive that contains the default path does not have sufficient free disk space for the restoration. The problem occurs because the SharePoint Portal Server restoration tries to restore all the server data and log files to the SharePoint Portal Server default path. The drive that contains the default path may not have sufficient disk space to restore the data.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   17-Jun-2002  18:47  10.145.4629.27  1,703,936  Mssrch.dll
   04-Jan-2002  23:26  10.145.4629.0      53,248  Spsqfe.exe
   18-Jun-2002  20:40                        137  Spsqfe.inf

Note Because of file dependencies, this update requires Microsoft SharePoint Portal Server 2001 Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to back up a SharePoint Portal Server, click the following article number to view the article in the Microsoft Knowledge Base:

281413 How to Back Up a SharePoint Portal Server


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbenv kbQFE kbbug kbfix kbSharePtPortalSvr2001preSP2fix KB323320