Event ID 1000, 108, or 102 may be logged when computers try to install software by accessing a share on a Windows NT 4.0-based file server (323304)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

This article was previously published under Q323304

SYMPTOMS

When Group Policy is configured to assign a software installation package to client computers that are running Microsoft Windows Server 2003, Microsoft Windows XP Professional, or Microsoft Windows 2000, the administrator must specify a share path that hosts the software installation files. If the specified share is located on a Microsoft Windows NT 4.0 file server, the software installation policy may not be successfully applied, and the following errors may be logged on the client computers for which installation was assigned:

Event message 1:

Source: UserEnv
Event ID 1000
The Group Policy client-side extension Application Management was passed flags (1) and returned a failure status code of (1612).

Event message 2:

Source: Application Management
Event ID 108
Failed to apply changes to software installation settings. Software changes could not be applied. A previous log entry with details should exist. The error was The installation source for this product is not available. Verify that the source exists and that you can access it.

Event message 3:

Source: Application Management
Event ID 102
The install of application "{Package Name}" from policy "{Policy Name}" failed. The error was The installation source for this product is not available. Verify that the source exists and that you can access it.

CAUSE

When programs are assigned to a computer, the computer tries to access the software installation share by using the credentials of the computer account. Computers that are running Windows Server 2003, Windows XP Professional, or Windows 2000 require Kerberos authentication. Windows NT 4.0 is not Kerberos-aware and can provide only NTLM authentication. Therefore, authentication is unsuccessful.

RESOLUTION

To resolve this issue, host software installation shares on Windows 2000-based or Windows Server 2003-based computers.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:2/15/2005
Keywords:kbprb KB323304