Effective Permissions Are Not Cleared When Control Is Indirectly Cleared (323074)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

This article was previously published under Q323074

SYMPTOMS

If you clear the permission check box control on the Security tab of the properties for a file system object, all of the applicable effective permissions are not cleared. As a result, you may allow or deny more permissions than you intend to.

For example, if the check box for the Full Control permission is selected, and you clear the check box for the Modify permission, the check box for the Full Control permission is automatically cleared. However, if you click the Advanced button to view the effective permissions, you see that the following permissions are incorrectly listed:
  • Delete Subfolders and Files
  • Change Permissions
  • Take Ownership
The permissions are correct if you clear the check box for the Full Control permission, and then click the check box for the Modify permission.

CAUSE

This problem occurs because the Security properties control state handlers do not explicitly mask off control values that are automatically cleared.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version         Size      File name 
   ---------------------------------------------------------- 
   18-Jul-2003  07:56   5.0.2195.6787   81,168    Aclui.dll 

WORKAROUND

To work around this problem, clear the check boxes for the permissions that are listed from top to bottom.

If you have indirectly cleared permissions because you performed the procedure that is described in the "Symptoms" section of this article, follow these steps to set the correct permissions:
  1. Click to select the check box for the Full Control permission, and then click Apply.
  2. Click to clear the appropriate check boxes from top to bottom, and then click Apply.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbWin2000preSP5fix kbbug kbenv kbpending kbQFE KB323074