SharePoint Portal Server Stops Responding (Hangs) When You Publish a Document (322805)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001 SP1
  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q322805

SYMPTOMS

When you try to publish a document in the Document Library, the portal may stop responding (hang). As a result, you cannot publish the document in Microsoft SharePoint Portal Server 2001.

CAUSE

This problem may occur if you publish a document when the Microsoft Search service (MSSearch) is in a state of recovery. For example, this problem may occur when MSSearch is shut down unexpectedly and you publish a document while the restart and recovery of MSSearch is still in progress. In this situation, Msdmserv threads are blocked in IGatherNotify::OnDataChange, and the portal stops responding (hangs).

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The Global version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date          Time      Size        File name    Version
---------------------------------------------------------------
08-May-2002   16:36PM   1,703,936   Mssrch.dll   10.145.4629.20
					

Note Because of file dependencies, this hotfix requires SharePoint Portal Server 2001 Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbfix kbbug KB322805 kbAudITPRO