Notification settings for the Advertised Programs Client Agent do not take effect on Legacy Client computers (322502)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

This article was previously published under Q322502

SYMPTOMS

When you change the Advertised Programs Client Agent settings on the Notification tab, and the Clients cannot change agent settings option is selected, the settings are not propagated to Legacy Client computers as expected.

CAUSE

The Advertised Program Monitor (Smsmon32.exe) uses cached settings until the SMS Client Service is restarted or until the next Client Configuration Installation Manager (CCIM) cycle.

WORKAROUND

To work around this issue, use one of the following methods:
  • Restart the SMS Client Service on the SMS client computer.
  • Restart the system to restart the SMS Client Service.
  • Log off and then log back on to the system.
  • Use the Cliutils.exe utility to start the CCIM cycle. For example, use the following command:

    Cliutils.exe KICK "Client Configuration Installation Manager"

Note If the Clients cannot change agent settings option is not selected, these workaround methods do not work. You must select this option if you want the settings to take effect on Legacy Client computers.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260293 SMS: Advertised programs monitor settings do not take affect for existing clients


Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbBug KB322502 kbAudITPRO