How to troubleshoot hardware and software driver problems in Windows XP (322205)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q322205

SYMPTOMS

After you install a new hardware device or new software, your computer may start to restart spontaneously, or you may receive error messages on a blue screen.

CAUSE

This behavior is typically caused by a device driver that is not correct for the version of Windows on which you installed it. Or, the device driver may have been poorly written, which can cause Windows to stop working correctly.

RESOLUTION

To troubleshoot these issues, follow the steps in the following sections.

Check third-party software or drivers

If you can start Windows XP

If you installed any third-party software or drivers, try removing them or disabling them so that they do not load. Then, restart the computer to see whether that software or driver is causing the issue. If that software or driver is causing the issue, report the problem to the manufacturer of the software or driver.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

308041 Resources for troubleshooting startup problems in Windows XP

If you cannot start Windows XP

If you cannot start Windows XP after you install the software or drivers, use one of the following methods to restore Windows:
  • Try using the Roll Back Driver feature: For more information about using the Roll Back Driver feature, click the following article number to view the article in the Microsoft Knowledge Base:

    283657 How to use the Roll Back Driver feature in Windows XP

  • Try using the Windows XP System Restore feature: For more information about using the System Restore feature, click the following article number to view the article in the Microsoft Knowledge Base:

    306084 How to restore the operating system to a previous state in Windows XP

  • Try using Recovery Console: For more information about using Recovery Console, click the following article number to view the article in the Microsoft Knowledge Base:

    307654 How to install and use the Recovery Console in Windows XP

  • Try starting MS-DOS:

    If Windows is installed on a partition that uses the FAT file system, try starting your computer to MS-DOS, and then renaming the problem software or driver.

Check new hardware

If you added any new hardware after you installed Windows, try removing the new device to see whether you stop receiving the "Stop 0x0A" error message. If removing the new device resolves the problem, try any or all of the following procedures:
  • Obtain updated drivers for the device, if any updated drivers are available.
  • Contact the manufacturer of the device to determine whether there are any known issues with the device.
  • Run diagnostics to make sure that the device is working properly.
  • Examine the logs in Event Viewer to see whether there is any event information that might help you to determine which device or driver is causing the problem.
  • Try using the Last Known Good Configuration feature: For more information about using the Last Known Good Configuration feature, click the following article number to view the article in the Microsoft Knowledge Base:

    307852 How to start your computer by using the Last Known Good Configuration feature in Windows XP

  • Try repairing the Windows XP installation. To do so:
    1. Turn off any antivirus program and BIOS-level antivirus protection. For help, see the appropriate software manual or online Help.
    2. Make sure that the CD-ROM or DVD-ROM drive is the first priority startup device in your computer's BIOS settings. See your computer's documentation for information about how to do this.
    3. Insert the Windows XP CD-ROM in the CD-ROM or DVD-ROM drive, and then restart your computer.
    4. When the "Press any key to boot from CD" prompt appears, press a key so that your computer starts from the Windows XP CD-ROM.
    5. When the computer starts from the CD-ROM, your hardware is checked, and then you are prompted to select an option. Press ENTER.
    6. Press F8 to accept the Licensing Agreement.
    7. Your current Windows XP installation is listed, and then you are prompted to select an option. Press R to start the automatic repair process. After Windows XP is repaired, you may have to reactivate Windows XP if you changed some hardware.
For information about how to contact the non-Microsoft manufacturer of your driver, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z


Modification Type:MajorLast Reviewed:10/26/2005
Keywords:kberrmsg kbDriver kbtshoot kbHardware kbhowto kbprb kbProd2Web KB322205