An hour glass appears and the program stops responding when you try to start MapPoint or Streets and Trips (322104)



The information in this article applies to:

  • Microsoft Autoroute 2006 English (United Kingdom)
  • Microsoft MapPoint 2006 Standard Edition
  • Microsoft MapPoint 2004 North American Maps
  • Microsoft MapPoint 2002
  • Microsoft Streets & Trips 2005
  • Microsoft Streets & Trips 2004
  • Microsoft Streets and Trips 2003
  • Microsoft Streets & Trips 2002 1.0

This article was previously published under Q322104

SYMPTOMS

When you try to start one of the products that is listed in the "Applies to" section for the first time, an hourglass appears, and then the program stops responding.

CAUSE

This behavior occurs when the Riched32.dll file is missing or corrupted.

RESOLUTION

To resolve this behavior, extract a copy of Riched32.dll from your Microsoft Windows CD. To do this, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Locate the Riched32.dll file

  1. Click Start, point to Search, and then click For Files or Folders.
  2. In the Named box, type riched32.dll, and then click Search Now.

    Note If you do not see Riched32.dll in the list of found files, go to the "Extract the Riched32.dll File" section.

    If you do see Riched32.dll in the list of found files, continue to follow these steps.

    The problem should be resolved at this point.
  3. In the list of found files, right-click Riched32.dll, and then click Rename.
  4. In the box that appears, type riched32.old, and then press ENTER.

    Note If you receive an error message that states that "access is denied" when you try to rename the Riched32.dll file, follow these steps:
    1. Click Start, and then click Shut Down.
    2. In the Shut Down Windows dialog box, click Restart in MS-DOS mode, and then click OK.
    3. At the command prompt, type the following commands, pressing ENTER after each command:

    cd\windows\system
    ren Riched32.dll Riched32.old
    exit

Extract the Riched32.dll file

Follow the steps for your version of Microsoft Windows.

Microsoft Windows 98

  1. Insert your Windows CD into your CD drive.
  2. Click Start, click Run, type sfc, and then press ENTER.
  3. Click Extract one file from installation disk.
  4. In the Specify the system file you would like to restore box, type Riched32.dll, and then click Start.
  5. In the Extract File dialog box, click Browse next to the Restore from box, and then locate your CD drive.
  6. Type drive:\Windows\System in the Save file in box, if it is not already there. In this example, drive is to the letter of the drive where your /Windows folder is located, typically this is drive C.
  7. Click OK.
  8. In the Backup File dialog box, click Skip, and then click OK.

Microsoft Windows Millennium Edition (Me)

  1. Click Start, click Run, type msconfig, and then press ENTER.
  2. In the System Configuration Utility dialog box, click the General tab, and then click Extract File.
  3. In the Extract one file from installation disk dialog box, type Riched32.dll, and then click Start.
  4. In the Restore from box, type drive:\Windows\options\install where drive refers to the letter of the drive where the \Windows folder is located, typically C.

    Note If the .cab files are not present on your hard disk, insert the Windows Millennium Edition (Me) CD, and then type drive:\Win9x, where drive is the drive letter of you CD drive, frequently drive D.
  5. In the Save file in box, type drive:\Windows\system, and then click OK.
  6. In the Backup File dialog box, click Skip.
  7. Click OK, and then click OK one more time to close the System Configuration Utility dialog box.

Microsoft Windows 2000

  1. Log on to your computer as an administrator.
  2. Click Start, click Run, type cmd, and then press ENTER.
  3. At the command prompt, type the following command, and then press ENTER:

    sfc /scannow

    This command invokes the System File Checker, which replaces the missing or renamed Riched32.dll file.

Microsoft Windows XP

  1. Click Start, click Run, type msconfig in the Open box, and then press ENTER.
  2. In the System Configuration Utility dialog box, click the General tab, and then click Expand File.
  3. In the File to restore box, type Riched32.dll.
  4. In the Restore from box, type drive:\Windows\options\install where drive refers to the letter of the drive where the \Windows folder, typically C.
  5. In the Save file in box, type drive:\Windows\system, and then click OK.
  6. Follow the instructions that appear on the screen to complete the extraction process.

Modification Type:MajorLast Reviewed:4/26/2006
Keywords:kbprb KB322104