PRB: Cannot Run Test if the Number of Users Is Not as Large as the Simultaneous Browser Connections (322087)



The information in this article applies to:

  • Microsoft Application Center Test, Developer Edition

This article was previously published under Q322087

SYMPTOMS

When you try to run a test in Application Center Test, the test may not work, and you may receive the following error message:
Connecting to the test clients...
The number of users X must be at least as large as the number of connections Y.
Unable to run the test. Either no test clients are available or a registration error has occurred. Error value: 0x80004004.
The test is no longer running.
NOTE: In the preceding error message, X is the number of users in the user group for the test, and Y is the number of simultaneous browser connections for the test.

CAUSE

This behavior may occur if the number of users for a test is not at least as large as the number of simultaneous browser connections. The number of users for a test must be at least as large as the number of simultaneous browser connections.

RESOLUTION

To workaround this behavior, use either of the following methods:
  • On the General tab in the properties of the test, modify the number of simultaneous browser connections to be equal to the number of users in the user group for the test.
  • Add additional users to the user group in the test to match the number of simultaneous browser connections.

STATUS

This behavior is by design.

Modification Type:MinorLast Reviewed:8/19/2005
Keywords:kberrmsg kbprb KB322087