Programs may not connect to the server with mismatched security DLLs in Windows NT 4.0 (322051)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP6a

This article was previously published under Q322051

SYMPTOMS

After you install the Microsoft Windows 2000 Security Rollup Package (SRP), or if you use NTLM version 2 to connect to a Windows NT 4.0-based server with the SRP installed, your programs may not connect to the server.

If Microsoft Exchange Server 5.5 is installed on a computer that is running Windows NT 4.0 with the SRP installed, and you try to move a mailbox from this server to a server that is running Microsoft Exchange 2000 Server, the following error may also be logged:
Event Source: MSExchangeAdmin
Event Category: Move Mailbox
Event ID: 1008
Description: Unable to move mailbox.
Error: Could not bind to the Microsoft Exchange Directory server. The Microsoft Exchange Server does not respond.

CAUSE

This behavior may occur if you install the SRP on Windows NT 4.0 with the 56-bit version of Service Pack 6a (SP6a) and Microsoft Internet Explorer 6, because the following mismatched dynamic-link libraries (DLLs) may be installed:
  • Schannel.dll (128-bit)
  • Ntlmssps.dll (128-bit)
  • Security.dll (56-bit)
This causes the Windows NT 4.0-based server to negotiate a 128-bit connection. However, the 56-bit security DLLs cannot decrypt the 128-bit packets. The Windows 2000 SRP forces NTLM version 2 connections with the Windows NT 4.0-based server.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows NT 4.0 Service Pack 6a installed.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date        Time  Size   File name    Platform
   -----------------------------------------------------------
   16-Jul-2001 12:05 36,112 Ntlmssps.dll I386 - 128-bit (SRP)
   23-Sep-1999 11:04 59,152 Security.dll I386 - 128-bit (SP6a)
   16-Jul-2001 12:05 36,112 Ntlmssps.dll I386 - 56-bit (SRP)
   18-Nov-1999 12:04 59,152 Security.dll I386 - 56-bit (SP6a)

WORKAROUND

To work around this problem, install the hotfix that is mentioned in the "Resolution" section. This upgrades the computer to 128-bit security.

If you must use the 56-bit versions of the DLLs in Windows NT 4.0, you can manually replace the Schannel.dll and Ntlmssps.dll files with the 56-bit versions from the SRP:
  1. Extract the files from the SRP. Use this command q299444i -x.
  2. Rename the current Schannel.dll and Ntlmssps.dll files in the %SystemRoot%\System32 folder.
  3. Copy the SRP versions of the Schannel.dll and Ntlmssps.dll files to the %SystemRoot%\System32 folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem may occur with Microsoft Exchange 5.5 administrative programs connecting to Exchange 5.5-based servers. This causes the following error message:
DS_E_COMMUNICATIONS_PROBLEM
When you join a Microsoft Exchange 2000 server to a Microsoft Exchange Server 5.5 site, you may receive the following error message:
Error code 0XC103FC93 (64659): Could not bind to the Microsoft Exchange Directory server EXCHANGE1.
The Microsoft Exchange Server computer does not respond. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

311401 Windows 2000 Security Rollup Package 1 (SR), January 2002

For more information about how to install multiple hotfixes while restarting only one time, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot


Modification Type:MajorLast Reviewed:11/2/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbWinNT400nospFix KB322051