Event ID 115 message occurs when you start SMTP service (322023)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Internet Security and Acceleration Server 2000
  • Microsoft Internet Security and Acceleration Server 2000 SP1
  • Microsoft Small Business Server 2000

This article was previously published under Q322023

SYMPTOMS

If you try to start the Simple Mail Transfer Protocol (SMTP) virtual server from Exchange System Manager, you may receive one of the following error messages:
The service did not respond to the start or control request in a timely fashion.
Check the Windows Event Viewer for details.
The service has returned a service-specific error code.
Check the Windows Event Viewer for details.
Additionally, the following event ID message is logged in the System log:

Source: SMTPSVC
Event ID: 115
Description:
The service could not bind instance 1. The data is the error code.
For additional information specific to this message please visit the Microsoft Online Support site located at: http://search.support.microsoft.com/search/?adv=1.

When you receive these error messages, you can run the following command from a command prompt:

Netstat -an | find ":25"

If you receive the following output when you run this command, a service other than SMTP is using port 25 on the server:

TCP 0.0.0.0:25 0.0.0.0:0 LISTENING

CAUSE

This behavior may occur if all of the following conditions are true:
  • Internet Security and Acceleration (ISA) Server and Exchange 2000 are installed on the same server.
  • ISA Server is configured to server publish SMTP.
  • Exchange 2000 Server is configured to use an SMTP virtual server on the same socket that ISA Server uses to server publish the SMTP service.

RESOLUTION

To resolve this behavior, configure Exchange 2000 so that it does not listen on the same socket as ISA Server (a socket is defined as IP address:port number). To server publish SMTP on the same server as ISA Server, you must configure the Exchange 2000 SMTP virtual server to listen only on the internal interface, and allow ISA Server to forward the incoming requests from the external interface to the internal interface.

Verify That You Are Server Publishing SMTP

To verify that you are server publishing SMTP:
  1. Start ISA Management. To do so, click Start, click Programs, click Microsoft ISA Server, and then click ISA Management.
  2. Expand Servers and Arrays, expand ServerName, expand Publishing, and then expand Server Publishing Rules.
  3. Double-click your SMTP server publishing rule to open its properties.

    NOTE: If you do not have a server publishing rule for SMTP (TCP port 25), this article does not apply to your issue. For additional information about other known causes for this behavior, see the "More Information" section.
  4. Verify the following settings:
    • On the General tab, make sure that the Enable check box is selected.
    • On the Action tab:
      • Make sure that the IP address of internal server is your server's internal (LAN) address.
      • Make sure that the external IP address on ISA server is your server's external (Internet) address.
      • Make sure that the mapped server protocol is the SMTP Server.
    • On the Applies To tab:
      • Any request is the default setting unless you have other specific business requirements.
If you change the server publishing rule, make sure that you restart the ISA Server Control service.

After you have verified that you are server publishing SMTP, configure Exchange 2000 to listen only on your internal IP address. To do so:
  1. Install and run MetaEdit on the server.For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

    232068 FILE: How to Download, Install, and Uninstall the IIS MetaEdit 2.2 Utility

  2. Expand LM, and then expand SMTPSVC.
  3. Right-click SMTPSVC, click New, and then click DWORD.
  4. In the ID List, click DisableSocketPooling.

    Make sure that 1029 appears in the box to the right. If DisableSocketPooling is not in the list, click (Other), and then type 1029.
  5. In the Data box, type 1.
  6. Restart the SMTP service.
  7. Start Exchange System Manager. To do so, click Start, click Programs, click Microsoft Exchange, and then click System Manager.
  8. Expand Servers, expand server name, expand Protocols, and then expand SMTP.

    NOTE: If Display Administrative groups is selected, you can find the Servers group under Administrative Groups, in the first administrative group, which is named Servers.
  9. Right-click your default SMTP virtual server, and then click Properties.
  10. Click your internal IP address in the IP Address box.
  11. Click Advanced, and then make sure that your external IP address does not exist (if it does, click it, and then click Remove).
  12. Click OK to close the Advanced Properties dialog box.
  13. Click OK to close the SMTP Virtual Server Properties dialog box.
  14. Right-click the SMTP virtual server, and then click Start.

STATUS

This behavior is by design.

MORE INFORMATION

You cannot multiplex Transmission Control Protocol (TCP) ports or used them more than one time in a session. You must stop one service from using a port before another service or program can use it.

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

281760 XCON: How to disable IIS socket pooling on the SMTP service

256132 Event ID 115 when configuring more than one virtual server on same IP address

Other Causes

If you do not have a server publishing rule for SMTP (TCP port 25), this article does not apply to your issue. There are several potential causes for this behavior. The most common issues include a third-party product that takes up TCP port 25 on the external interface. To troubleshoot this issue, turn off programs such as antivirus e-mail gateways.

Modification Type:MajorLast Reviewed:7/17/2006
Keywords:kbprb KB322023