Fix: Receive Functions Cannot Recover from SQL Failover (321950)



The information in this article applies to:

  • Microsoft BizTalk Server 2002

This article was previously published under Q321950

SYMPTOMS

If you set up a BizTalk server as a receive-only server, and the computer that is running Microsoft SQL Server for the BizTalk server fails, the receive functions of BizTalk server may stop responding even after you restart the computer that is running SQL Server.

CAUSE

The receive-only server does not have a refresh thread to monitor SQL Server failures; therefore, the BizTalk server does not restart the BizTalk Messaging Service when the SQL server restarts.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft BizTalk Server 2002. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

815781 How to Obtain the Latest BizTalk Server 2002 Service Pack

Hotfix Information


A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size      File name
   -----------------------------------------------------------------
   Apr-29-2002  14:22  3.0.1512.0   508,176   Ciscore.dll
   Apr-29-2002  14:22  3.0.1512.0   401,680   Cisengine.dll
   Apr-29-2002  14:22  3.0.1512.0   327,952   Mscis.exe
   Apr-11-2002   9:41                13,680   BTM_priorityUpgrade.sql
   Apr-11-2002   9:41                19,632   SQ_PriorityUpgrade.sql
				

To apply the fix, follow these steps:
  1. Stop the BizTalk Messaging Service.
  2. Apply the new .dll files and the new .exe file to the Biztalk Server 2002 installation directory.
  3. Use the SQL Query Analyzer to apply BTM_PriorityUpgrade.sql to the InterchangeBTM database.
  4. Use the SQL Query Analyzer to apply SQ_PriorityUpgrade.sql to the InterchangeSQ database.
  5. Start the BizTalk Messaging Service.
All servers that share the database must be upgraded. Any servers with the old files fail to start after the InterchangeBTM and InterchangeSQ databases have been updated.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in Microsoft BizTalk Server 2002 Service Pack 1.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbBizTalk2002SP1fix kbbug kbfix KB321950