"Incompatible Version of the RPC Stub" Error Message with the InstallShield Program (321915)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6a

This article was previously published under Q321915

SYMPTOMS

When you install a program that uses the InstallShield program, you may receive the following error message:
Unhandled Exception

Error: 0x80070725
Description: Incompatible version of the RPC stub.

Setup will now terminate.

CAUSE

This issue may be caused by any program that installs different versions of the Oleaut32.dll, Olepro32.dll, Asycfilt.dll, and Stdole2.tlb files (and possibly others). This may create a mixed file version environment with files that are not compatible with each other.

RESOLUTION

To resolve this issue, use the appropriate method.

Microsoft Office 2000 or an Office 2000 Component Is Installed on Your Computer

If Office 2000 or an Office 2000 component is installed on your computer, obtain and install the Office 2000 Service Release 1a (SR-1a). For information about how to do so, please visit the following Microsoft Web site:

Microsoft Office 2000 or an Office 2000 Component Is Not Installed on Your Computer

If Office 2000 or an Office 2000 component is not installed on your computer, obtain and install the Mcrepair.exe tool. To do so, please visit the following Microsoft Web site, save the Mcrepair.exe file to the desktop, and then run Mcrepair.exe: Restart your computer after you install Mcrepair.exe.

MORE INFORMATION

Office 2000 SR-1 and the Mcrepair.exe tool both update and re-register the following files with the following file versions:
  • Asycfilt.dll (2.40.4515)
  • Oleaut32.dll (2.40.4515)
  • Stdole2.tlb (2.40.4515
  • Olepro32.dll (5.0.4515)
For additional information about the error message that is listed in the "Symptoms" section of this article, please view Q105810 in the InstallShield Knowledge Base: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

Acknowledgment: InstallShield contributed to this Microsoft Knowledge Base article.

Modification Type:MajorLast Reviewed:9/13/2006
Keywords:kbdownload kb3rdparty kbenv kberrmsg kbprb kbsetup KB321915