Toshiba 5005 Portable Computer Stops Responding During Upgrade from Windows XP Home Edition to Windows XP Professional (321645)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q321645

SYMPTOMS

When you try to upgrade a Toshiba Satellite 5005-series portable computer from Windows XP Home Edition (OEM version) to Windows XP Professional, the computer may stop responding ("hang"). This generally occurs the first time the computer restarts during setup, at the Windows XP Professional splash screen.

CAUSE

This behavior may occur if all the following conditions are true:
  • You use one of the following Toshiba 5005 series portable computers, and the Original Equipment Manufacturer (OEM) Windows XP Home Edition is preinstalled on it:
    • Toshiba Satellite 5005-S504
    • Toshiba Satellite 5005-S507
  • You upgrade the OEM installation of Windows XP Home Edition to Windows XP Professional.
  • The Smart media driver preinstalled by the manufacturer is enabled.
  • The Secure Digital (SD) driver preinstalled by the manufacturer is enabled.

WORKAROUND

To work around this issue, disable the currently installed OEM drivers for the SD card and Smart media controller before you run the upgrade. To do this, follow these steps:
  1. Restart the computer to Windows XP Home Edition.
  2. In Control Panel, open the System tool.
  3. On the Hardware tab, click Device Manager.
  4. Expand the SD Card Controller node.
  5. Right-click TOSHIBA SD Card Controller Type A, and then click Disable. Click Yes when you are prompted to disable the device.
  6. Expand the IDE ATA/ATAPI Controllers node.
  7. Right-click Toshiba PCI-0804 SmartMedia Host Controller, and then click Disable. Click Yes when you are prompted to disable the device.
  8. Insert the Windows XP Professional CD-ROM into the computer's CD-ROM or DVD-ROM drive (if it is not inserted already), and then run Setup to upgrade the computer to Windows XP Professional.
  9. After the upgrade process is completed, enable the devices in Device Manager.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

For additional information about how to install Windows XP Professional, click the article numbers below to view the articles in the Microsoft Knowledge Base:

286463 Release Notes for Windows XP Setup Contained in the Pro.txt File

316941 HOW TO: Install Windows XP


Modification Type:MajorLast Reviewed:4/30/2003
Keywords:kbprb KB321645