"Operating System Not Found" or "Missing operating system" error message when you start your Windows XP-based computer (321626)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q321626

SUMMARY

When you try to start your Microsoft Windows XP-based computer, you may receive an error message that the operating system is not found. This issue can be caused by hard disk drive failure, incorrect BIOS settings, a damaged or missing Master Boot Record (MBR), or an incorrect active partition. To resolve this issue, correct the computer's BIOS settings, use the Windows XP Recovery Console, or mark the correct partition on your hard disk drive as active.

SYMPTOMS

When you start your Microsoft Windows XP-based computer, you may receive one of the following error messages:
Operating system not found.
Missing Operating System
When you start your computer to the Recovery Console to recover functionality, you may receive an error message that is similar to the following error message:
Setup did not find any hard drives installed on your computer.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • The basic input/output system (BIOS) does not detect the hard disk.
  • The hard disk is damaged.
  • Sector 0 of the physical hard disk drive has an incorrect or malformed Master Boot Record (MBR).

    Note Some third-party programs or disk corruption can damage an MBR.
  • An incompatible partition is marked as Active.
  • A partition that contains the MBR is no longer active.

RESOLUTION

To resolve this issue, use one of the following methods, depending on your situation.

Method 1: Verify the BIOS settings

Verify the computer's BIOS settings to make sure that BIOS lists and recognizes the hard disk. See the computer documentation or contact the hardware manufacturer for information about how to verify the BIOS settings.

After you verify that the computer's BIOS detects the hard disk, restart the computer, and then test to determine whether the issue is resolved. If the issue is not resolved, or if the computer's BIOS cannot detect the hard disk, you may have issues with your hardware. Contact the hardware manufacturer to inquire about how to resolve this issue. You may have to replace the hard disk.

For information about how to contact hardware manufacturers, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Method 2: Use Recovery Console

Use the fixmbr command in the Windows XP Recovery Console to repair the MBR of the startup partition.

For additional information about Recovery Console, click the following article number to view the article in the Microsoft Knowledge Base:

314058 Description of the Windows XP Recovery Console

307654 How to install and use the Recovery Console in Windows XP

Method 3: Change the active partition

If the partition marked as active does not contain the Windows XP startup files, or the active partition is an incompatible or a different operating system, you must first mark the correct system partition as active before you restart the computer.

Note There can be only one active system partition at a time.

For additional information about how to mark the active partition, click the following article number to view the article in the Microsoft Knowledge Base:

315261 The computer does not start after you change the active partition by using the Disk Management tool

MORE INFORMATION

For additional information about how to troubleshoot startup problems in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

308041 Resources for troubleshooting startup problems in Windows XP


Modification Type:MajorLast Reviewed:7/21/2004
Keywords:kberrmsg kbprb KB321626 kbAudEndUser