Saving an .ini File Over the Network Causes a 40-Second Delay (321412)
The information in this article applies to:
- Microsoft Windows XP Home Edition
- Microsoft Windows XP Professional
This article was previously published under Q321412 SYMPTOMS
If you save an .ini file over the network to a Windows XP-based computer, the save operation may take up to 40 seconds to finish. If you save the same file again, there is no delay.
CAUSE
The delay is caused by a deadlock between the System Restore tool on the server and the redirector on the client. The problem affects all files that are monitored by System Restore.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
--------------------------------------------------
08-May-2002 17:32 5.1.2600.44 70,400 Sr.sys
WORKAROUND
To work around this problem, turn off System Restore on the server. You can turn off System Restore only for the partition that contains the shared .ini files.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.
Modification Type: | Minor | Last Reviewed: | 9/27/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbWinXPsp1fix KB321412 |
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