Games: "Unable to create or access required directory" or "Can't open the data files" error message appears when you try to start the game (321408)



The information in this article applies to:

  • Microsoft Dungeon Siege 1.0
  • Dungeon Siege: Legends of Aranna
  • Microsoft Flight Simulator 2004 - Century of Flight

This article was previously published under Q321408

SYMPTOMS

When you try to start one of the games that is listed in the "Applies to" section, you may receive an error message that is similar to one of the following:
Dungeon Siege Unable to create or access required directory!
DirectX 8 failed to initialize. Either DirectX 8 is not installed on this system or your hardware does not support DirectX 8.
A fatal error has occured and the app must be shut down. Please check your home command line settings.
When you start the game in Microsoft Windows XP, the program may stop responding (hang) or quit unexpectedly.

CAUSE

This issue may occur if your My Documents folder is not in a location that your user profile can access.

When Dungeon Siege starts, it tries to create a Dungeon Siege folder in the My Documents folder. If the My Documents folder is not in a location that is accessible to your user profile, Dungeon Siege cannot create the folder.

RESOLUTION

To resolve this issue, move the My Documents folder to the default location. To do this, follow these steps.Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, right-click My Documents, and then click Properties.
  2. In the Target box, type drive:\Documents and Settings\user\My Documents, where drive is the drive on which Windows is installed and user is your user name.
  3. Click Apply, and then click OK.
  4. When you are prompted to confirm that you want to create the folder, click Yes.
  5. When you are prompted to confirm that you want to move all the documents with the folder, click Yes to All.

Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kbConfig kberrmsg kbprb KB321408