You receive an error message when you use the Msdmback.vbs backup utility (321251)



The information in this article applies to:

  • Microsoft SharePoint Portal Server 2001

This article was previously published under Q321251
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you try to use the Msdmback.vbs backup utility to back up Microsoft SharePoint Portal Server 2001, you may receive an error message similar to one of the following:

Error message 1

Error: An error occurred during backup. See the event log for more details.
ErrNo: 80070005
Desc: Access is denied.
Source: MSSearch.Admin.1

Error message 2

Error: An error occurred during backup. See the event log for more details.
ErrNo: 80010105
Desc: The server threw an exception.
Source: MSSearch.Admin.1

Error message 3

Error: An error occurred during backup. See the event log for more details.
ErrNo: 80010105
Desc: Method '~' of object '~' failed
Source: MSDMBack

Error message 4

Error fetching URL, (80040d77 - The property list for the content class of this document cannot be loaded, and the schema cannot be accessed; Make sure the schema is correctly configured.)

CAUSE

There is a problem with the DefaultPluginAccount value, which is located in the following registry path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Search\1.0\Gathering Manager

WORKAROUND

To work around this issue, use one the following methods.

Configure the Backup Account by Using Msdmback.vbs

  1. At a command prompt, type the following commands and press ENTER after each command

    cd /d "c:\program files\sharepoint portal server\bin"
    cscript.exe msdmback.vbs /a username password

    where username and password are valid settings for an account with administrator permissions on your server. Alternatively, you can use a domain account by typing the user name with the domain\username syntax.
  2. Close the command prompt.
  3. Restart your server.

Delete the DefaultPluginAccount Registry Value

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start the Registry Editor (Regedt32.exe).
  2. Locate the DefaultPluginAccount value under the following key in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Search\1.0\Gathering Manager

    NOTE: The registry key is one path; it has been wrapped for readability.

  3. On the Edit menu, click Delete, and then click Yes.
  4. Quit the Registry Editor.
  5. Restart your server.

MORE INFORMATION

The DefaultPluginAccount registry value does not to exist until you use the msdmback /a command to specify which account is used for backup and restore operations.

For example, if you type the following commands at a command prompt, you set the user account:

cd /d "c:\program files\sharepoint portal server\bin"
cscript.exe msdmback.vbs /a username password

This registry value is read when MSSEARCH service is started. When there is a problem with this user account, the Msdmback.vbs utility cannot complete and returns an error.

For additional information about how to use the Msdmback.vbs utility with SharePoint Portal Server, click the following article numbers to view the articles in the Microsoft Knowledge Base:

281413 How to back up a SharePoint Portal Server

292719 How to back up and restore server data in SharePoint Portal Server 2001 by using the Msdmback.vbs script


Modification Type:MajorLast Reviewed:11/2/2005
Keywords:kbprb KB321251