SYMPTOMS
A COM Transaction Integrator (COMTI) method call works one time, and
none of the following calls succeeds until the Component Services
application package shuts down. Each time that a call is unsuccessful,
Component Services posts a COMTI Event 102 in the application event log
with the following details:
Exception description:
(1304) COM Transaction Integrator was unable to process the method
because the Transaction Server is in the process of stopping. Retry the
operation later.
NOTE: The Component Services application package can shut down
in one of the following ways:
- Automatically: if the Minutes until idle
shutdown option is set. (The default setting is three
minutes.)
- Manually: when you open the Component Services manager, right-click
the Application Package, and then click Shut down.
CAUSE
This problem occurs when you apply COM+ Hotfix Rollup Package 19 or
later and if you use COMTI with SNA Server 4.0 and Host Integration
Server 2000.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
318105 INFO: Availability of Windows 2000 Post-Service Pack 2 COM+ Hotfix Rollup Package 19
RESOLUTION
Host Integration Server 2000
To resolve this problem, obtain the latest service pack for Host Integration Server 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
328152 How to Obtain the Latest Host Integration Server 2000 Service Pack
The English version of this fix should have the following file
attributes or later:
|
tagen.dll | 08-Apr-2002 | 09:40 |
NOTE: Because of file dependencies, the most recent fix that
contains the preceding files may also contain additional files.
SNA Server 4.0
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft SNA Server version 4.0 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:
NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English version of this fix should have the following file
attributes or later:
|
tagen.dll | 05-Apr-2002 | 15:52 |
NOTE: Because of file dependencies, the most recent fix that
contains the preceding files may also contain additional files.