Cannot Change Password if You Use the UPN Suffix (321074)
The information in this article applies to:
- Microsoft Windows Server 2003, Enterprise Edition
- Microsoft Windows Server 2003, Standard Edition
- Microsoft Windows XP Professional
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
This article was previously published under Q321074 SYMPTOMS
If you try to use the User Principal Name (UPN) (user name@UPN domain suffix) in the Change Password dialog box, you may receive an error message that states that the domain cannot be contacted or that the password is incorrect.
This symptom only occurs on a domain member with a user who has a UPN domain suffix that does not match the Active Directory DNS domain name (in this case, the alternative UPN suffix is used).
Note that this symptoms does not occur if you only use the ordinary user name and you select the NetBIOS domain name in the Change Password dialog box (as with NTLM).
CAUSE
This behavior may occur when the built-in Authenticated Users group was removed from the organizational unit where the user account resides. By default, the computer account is a member of the Authenticated Users group. If you use the Change Password dialog box, the local computer account is used to resolve the UPN. If the Authenticated Users group was removed from the organizational unit that contains the user account, you cannot successfully change the password.
RESOLUTION
To work around this behavior, give the computer account read access to the organizational unit that contains the user account, or use the NTLM naming convention (NetBIOS domain name\user name) instead of the UPN.
STATUSThis behavior is by design.
Modification Type: | Major | Last Reviewed: | 3/30/2004 |
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Keywords: | kbprb kbui KB321074 |
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