XCON: Messages That Are Sent from Lotus Notes Are Redirected to the Badmail Folder (321067)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q321067
Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.
Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
Note An antivirus program is designed to help protect your computer from viruses. You must not download or open files from sources that you do not trust, visit Web sites that you do not trust, or open e-mail attachments when your antivirus program is disabled.

For additional information about computer viruses, click the following article number to view the article in the Microsoft Knowledge Base:

129972Computer viruses: description, prevention, and recovery

IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you send messages by using any IBM Lotus Notes client of IBM Lotus Domino Server version R5.0.4, the messages may be redirected to the Badmail folder.

CAUSE

This issue may occur when all the following conditions are true:
  • The messages are sent through the Microsoft Exchange Connector for Lotus Notes to Exchange Server 5.5 Service Pack 3 or 4 (SP3 or SP4) recipients.
  • The Lotus Notes client is installed on an Exchange 5.5 computer that is hosting Microsoft Exchange Connector for Lotus Notes.
  • You send the messages from Lotus Notes through IBM Lotus Domino Server version R5.0.4 to the Exchange 5.5 computer that hosts the connector.
  • The Exchange 5.5 computer is running Symantec Norton AntiVirus for Microsoft Exchange.
  • The attachment from the Lotus Notes client is compressed.

When messages pass through the connector and arrive in the Exchange Server Badmail folder, the following information may be recorded in the connectivity log:

08-Jan-2002 22:39:17- LME-NOTES-NTSMEX(01f9) 4 41255:Successfully acquired the next inbound next message
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31200:Exchange Server has returned the condition: 80004005
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31201:Microsoft Package ID: General Error 08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31202:Extended MAPI information: Error: ????????????????
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31202:a
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31202: Component: No additional information available Version: 0 Low Level Error: 50a Context: 501
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31203:Extended NT information: Unspecified error
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31053:Message content contains invalid information
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31053:Message content contains invalid information
08-Jan-2002 22:39:17- LME-NOTES-MEXIN(01e8) 2 31074:Moving message with invalid syntax to Bad Mail Folder

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this issue, use one of the following four options:
  • Send the message and do not select the compress option in the Lotus Notes client.
  • Remove Norton AntiVirus for Microsoft Exchange.
  • Modify the VirusScan registry key by using Registry Editor. To do this, follow these steps.

    WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    1. Click Start, click Run, type regedt32.exe, and then click OK.
    2. Locate the VirusScan key in the registry:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\VirusScan

    3. Edit the OpenRetryDelay registry key, and set the value to 25000.

      The registry key is defined as follows:

      Value Name: OpenRetryDelay
      Data Type: REG_DWORD
      Radix: Decimal
      Value: 500 (default)
      Description: The time interval in milliseconds that the information store pauses before the information store attempts to reopen an attachment that is currently being scanned when the attachment is requested by the client. If this value is set too high, clients may time out, but if this value is set too low, additional processing overhead by the information store may occur.

    4. Quit Registry Editor.
  • Stop and then restart the Information Store service. You do not have to restart the Exchange Server computer.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB321067