PRB: Profile Publishing Stops Responding After You Delete Any Profile (320967)



The information in this article applies to:

  • Microsoft Commerce Server 2002

This article was previously published under Q320967

SYMPTOMS

After you delete a profile from the Commerce Server Solution Sites, Business Desk (BizDesk) may stop responding when you try to publish a profile, and you receive the following error message:
Publish of profiles failed.
The detailed error message is as follows:
Error: 0xC1004004
Description: The current operation has been performed using an invalid profile type.

CAUSE

In the Solution Sites, the refresh mechanism tries to create each profile type. Therefore, when any profile is deleted, BizDesk stops responding when you try to publish a profile.

WORKAROUND

To remove a profile that is no longer in the profile catalog, modify the function dictGetProfileSchemaForAllProfileTypes in the global_profile_lib.asp under the include directory of the site. For example, if the Address profile is deleted, do the following:
  1. Comment out the following lines as follows:
    'Set oAddress = oProfileService.CreateProfile(MODEL_ADDRESS,PROFILE_TYPE_ADDRESS)
    '
    ' ...
    ' ...
    '
    'Set oProfileDefsCatalog = oGetProfile (oBizData, PROFILE_TYPE_ADDRESS)    
    'Set oProfileProperties(PROFILE_TYPE_ADDRESS) = listGetProfileSchema (oAddress, _
    '                oProfileDefsCatalog, oSiteTermsProfile)<BR/>
    'Set oAddress = Nothing
    'Set oProfileDefsCatalog = Nothing
    					
    Perform an IISRESET.Click Refresh on the BizDesk Profiles module.
  2. Perform an IISRESET.Click Refresh on the BizDesk Profiles module.
  3. Click Refresh on the BizDesk Profiles module.
You can now publish the profile successfully.

MORE INFORMATION

The Retail 2002 (.NET) solution site does not use the global_profile_lib.asp.

Modification Type:MajorLast Reviewed:10/22/2002
Keywords:kbprb KB320967