PRB: Subject Line Becomes "?" in EML Files When URL Content Is an English Language Web Site (320957)



The information in this article applies to:

  • Microsoft Commerce Server 2002

This article was previously published under Q320957

SYMPTOMS

If an e-mail message has a Japanese language subject line and an English language Web site URL in the message text, when you view the message, the subject line and the title bar of the message become 90%?????.

CAUSE

This behavior occurs because of a problem in the program that you use to view the message.

Because you have not specified an encoding for the recipient (or for the direct mail job), the Collaboration Data Object (CDO) selects the encoding automatically, and then sends the message:
  • If both the subject line and the message body contain Japanese language text, the CDO correctly selects shift-jis.
  • If the subject line is in Japanese and the message body is in English, the CDO selects western ISO.
If you open the .eml file as flat file, the subject line also appears as "?". This occurs because the URL that you use in the message body is for a Web site that uses the following encoding. (This example is from the source code of the Microsoft Web site.)
charset=iso-8859-1
				
NOTE: The message is displayed correctly if you use a China Web site address (for example, http://www.microsoft.com/china).

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. Create a new direct mail campaign in Campaign Manager.
  2. Type double-byte character set (DBCS) characters in the message subject text box.
  3. Type an English language Web site URL in the file path or URL containing message body text box. (for example, http://www.microsoft.com).
  4. Send a test e-mail message.
  5. Open the e-mail message under the e-mail delivery folder.

Modification Type:MajorLast Reviewed:10/25/2002
Keywords:kbprb KB320957