You receive an error message when you install or start Visual Studio .NET or Visual Studio 2005: "Unable to pre-create directory for profile files" (320930)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition
  • Microsoft Visual C++ .NET (2003)
  • Microsoft Visual C++ .NET (2002)
  • Microsoft Visual Basic .NET (2003)
  • Microsoft Visual Basic .NET (2002)
  • Microsoft Visual C# .NET (2003)
  • Microsoft Visual C# .NET (2002)
  • Microsoft Visual J# .NET 2002
  • Microsoft Developer Network (MSDN)

This article was previously published under Q320930

SYMPTOMS

When you try to install or start Microsoft Visual Studio .NET or Microsoft Visual Studio 2005, you may receive the following error message:
Unable to pre-create directory for profile files

CAUSE

This issue may be caused by either of the following conditions:
  • This issue may occur after the default Full Control for Everyone and Administrator in the Profile folder file structure has been changed. Note that this can only occur in an NTFS file system.
  • This issue may occur if the profiles are missing.

RESOLUTION

To resolve this issue, use one of the following methods:
  • Correct the file permissions for the user's profile and the All Users folder. Use (as a minimum) Read permissions. As with all folders, the local administrator must have Full Control.

    Note You do not have to remove Visual Studio .NET or Visual Studio 2005 and you do not have to install either version again. You also do not have to complete a repair on Visual Studio .NET or Visual Studio 2005. None of these processes can resolve this issue.
  • Make sure that the profiles are not missing. The user profile folder is located in:
    • Microsoft Windows NT 4.0: system partition letter:\WinNT\Profiles\user account\
    • Microsoft Windows 2000 and Microsoft Windows XP: system partition letter:\Documents and Setting\user account\
    • Microsoft Windows Server 2003, Microsoft Windows 2000 and Microsoft Windows XP that have been upgraded from Microsoft Windows 98, Microsoft Windows 95 or Microsoft Windows Millennium Edition: system partition letter:Windows\Profiles\user account\
  • Make sure that the All Users profile is not missing. The All Users profile folder is located in:
    • Microsoft Windows NT 4.0: system partition letter:\WinNT\Profiles\All Users\
    • Microsoft Windows Server 2003, Microsoft Windows 2000 and Microsoft Windows XP: system partition letter:\Documents and Setting\All Users\
    • Microsoft Windows Server 2003, Microsoft Windows 2000 and Microsoft Windows XP that have been upgraded from Microsoft Windows 98, Microsoft Windows 95 or Microsoft Windows Millennium Edition: system partition letter:Windows\Profiles\All Users\

REFERENCES

319714 How to troubleshoot Visual Studio .NET installation


Modification Type:MajorLast Reviewed:3/7/2006
Keywords:kbvs2005applies kbvs2005swept kbenv kberrmsg kbprb kbsetup KB320930 kbAudDeveloper